aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 58a1ad15d..094189058 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,10 +593,10 @@ AC_ARG_ENABLE(shout,
[enables the shoutcast streaming output (default: disable)]),,
[enable_shout=no])
-if test x$enable_oggvorbis_encoder = xyes || test x$enable_lame_encoder = xyes; then
- PKG_CHECK_MODULES([SHOUT], [shout],,
- [enable_oggvorbis_encoder=no; enable_lame_encoder=no;
- AC_MSG_WARN([disabling shout streaming support because libshout is not available])])
+if test x$enable_shout = xyes; then
+ PKG_CHECK_MODULES([SHOUT], [shout],
+ AC_DEFINE(HAVE_SHOUT, 1, [Define to enable libshout support]),
+ enable_shout=no)
fi
if test x$enable_oggvorbis_encoder = xyes; then
@@ -628,13 +628,6 @@ if test x$enable_lame_encoder = xyes; then
fi
fi
-if test x$enable_oggvorbis_encoder = xyes || test x$enable_lame_encoder = xyes; then
- enable_shout=yes
- AC_DEFINE(HAVE_SHOUT, 1, [Define to enable libshout support])
-else
- enable_shout=no
-fi
-
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_shout = xyes || test x$enable_httpd_output = xyes)