aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4dec85891..212b618e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,19 @@ fi
dnl i18n
+
+AC_MSG_CHECKING([national language support])
+AC_ARG_ENABLE([nls],
+ AS_HELP_STRING([--enable-nls], [Enable national language support]),
+ [enable_nls=$enableval],
+ [enable_nls=$disable_mini])
+AC_MSG_RESULT([$enable_nls])
+
+if test "x$enable_nls" = xno; then
+ glib24=no
+ nls=no
+fi
+
AM_NLS
if test "x$glib24" = "xyes"; then
nls=$USE_NLS