aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e3e68eec1..1baa12f17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,12 @@ if test "x$ncurses" = "xauto"; then
[ncurses=ncurses])
fi
+AC_CHECK_HEADER([ncursesw/ncurses.h],
+ [have_ncursesw_h=yes],
+ ,)
+
+
+
AC_CHECK_LIB([$ncurses],
[initscr],
@@ -89,12 +95,15 @@ AC_CHECK_LIB([$ncurses],
[AC_MSG_ERROR($ncurses library is required)])
-if test "x$ncurses" = "xncursesw" ; then
- AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, [wide-char wget_ch()])
- AC_DEFINE(USE_NCURSESW, 1, [use wide-char ncurses library])
+if test "x$ncurses" != "xncursesw" ; then
+ if test "x$have_ncursesw_h" = "xyes" ; then
+ AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, [wide-char wget_ch()])
+ AC_DEFINE(USE_NCURSESW, 1, [use wide-char ncurses library])
+ fi
fi
+
dnl Check for glib-2.4
PKG_CHECK_MODULES([GLIB],
[glib-2.0 >= 2.4],