aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6067bc480..5630fe650 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,12 @@ if test x$GCC = xyes
then
MPD_CHECK_FLAG([-Wall])
MPD_CHECK_FLAG([-Wextra])
- MPD_CHECK_FLAG([-Wno-unused-parameter])
MPD_CHECK_FLAG([-Wno-deprecated-declarations])
MPD_CHECK_FLAG([-Wmissing-prototypes])
MPD_CHECK_FLAG([-Wdeclaration-after-statement])
MPD_CHECK_FLAG([-Wshadow])
+ MPD_CHECK_FLAG([-Wpointer-arith])
+ MPD_CHECK_FLAG([-Wstrict-prototypes])
fi
if test -z "$prefix" || test "x$prefix" = xNONE; then