aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 882fd4e05..b70999b5c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1154,6 +1154,7 @@ C_TESTS = \
test/test_byte_reverse \
test/test_mixramp \
test/test_pcm \
+ test/test_translate_song \
test/test_queue_priority
if ENABLE_ARCHIVE
@@ -1625,6 +1626,21 @@ test_test_archive_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+test_test_translate_song_SOURCES = \
+ src/PlaylistSong.cxx \
+ src/DetachedSong.cxx \
+ src/Log.cxx \
+ test/test_translate_song.cxx
+test_test_translate_song_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_translate_song_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_translate_song_LDADD = \
+ libtag.a \
+ libfs.a \
+ libsystem.a \
+ libutil.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_queue_priority_SOURCES = \
src/Queue.cxx \
test/test_queue_priority.cxx