aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5e3f3b260..fe3932975 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,6 +31,7 @@ src_mpd_CPPFLAGS = $(AM_CPPFLAGS) \
src_mpd_LDADD = \
$(NEIGHBOR_LIBS) \
$(DB_LIBS) \
+ $(STORAGE_LIBS) \
$(PLAYLIST_LIBS) \
$(AVAHI_LIBS) \
$(LIBWRAP_LDFLAGS) \
@@ -410,6 +411,20 @@ libfs_a_SOURCES = \
src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/DirectoryReader.hxx
+# Storage library
+
+if ENABLE_DATABASE
+
+noinst_LIBRARIES += libstorage.a
+
+libstorage_a_SOURCES = \
+ src/storage/LocalStorage.cxx src/storage/LocalStorage.hxx \
+ src/storage/FileInfo.hxx
+
+STORAGE_LIBS = libstorage.a
+
+endif
+
# neighbor plugins
if ENABLE_NEIGHBOR_PLUGINS