aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am121
1 files changed, 82 insertions, 39 deletions
diff --git a/Makefile.am b/Makefile.am
index 7240cb3f1..0448cf416 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ src_mpd_SOURCES = \
src/command/CommandError.cxx src/command/CommandError.hxx \
src/command/AllCommands.cxx src/command/AllCommands.hxx \
src/command/QueueCommands.cxx src/command/QueueCommands.hxx \
+ src/command/TagCommands.cxx src/command/TagCommands.hxx \
src/command/PlayerCommands.cxx src/command/PlayerCommands.hxx \
src/command/PlaylistCommands.cxx src/command/PlaylistCommands.hxx \
src/command/DatabaseCommands.cxx src/command/DatabaseCommands.hxx \
@@ -146,7 +147,9 @@ src_mpd_SOURCES = \
src/ClientFile.cxx src/ClientFile.hxx \
src/Listen.cxx src/Listen.hxx \
src/LogInit.cxx src/LogInit.hxx \
+ src/LogBackend.cxx src/LogBackend.hxx \
src/Log.cxx src/Log.hxx src/LogV.hxx \
+ src/LogLevel.hxx \
src/ls.cxx src/ls.hxx \
src/IOThread.cxx src/IOThread.hxx \
src/Main.cxx src/Main.hxx \
@@ -170,6 +173,7 @@ src_mpd_SOURCES = \
src/PlaylistGlobal.cxx src/PlaylistGlobal.hxx \
src/PlaylistControl.cxx \
src/PlaylistEdit.cxx \
+ src/PlaylistTag.cxx \
src/PlaylistPrint.cxx src/PlaylistPrint.hxx \
src/PlaylistSave.cxx src/PlaylistSave.hxx \
src/PlaylistMapper.cxx src/PlaylistMapper.hxx \
@@ -198,7 +202,6 @@ src_mpd_SOURCES = \
src/TagPrint.cxx src/TagPrint.hxx \
src/TagSave.cxx src/TagSave.hxx \
src/TagFile.cxx src/TagFile.hxx \
- src/TextFile.cxx src/TextFile.hxx \
src/TextInputStream.cxx \
src/Volume.cxx src/Volume.hxx \
src/SongFilter.cxx src/SongFilter.hxx \
@@ -245,6 +248,7 @@ endif
libutil_a_SOURCES = \
src/util/Macros.hxx \
+ src/util/Clamp.hxx \
src/util/Error.cxx src/util/Error.hxx \
src/util/Domain.hxx \
src/util/ReusableArray.hxx \
@@ -252,19 +256,22 @@ libutil_a_SOURCES = \
src/util/CharUtil.hxx \
src/util/NumberParser.hxx \
src/util/StringUtil.cxx src/util/StringUtil.hxx \
+ src/util/SplitString.cxx src/util/SplitString.hxx \
src/util/FormatString.cxx src/util/FormatString.hxx \
src/util/Tokenizer.cxx src/util/Tokenizer.hxx \
src/util/UriUtil.cxx src/util/UriUtil.hxx \
src/util/Manual.hxx \
src/util/RefCount.hxx \
- src/util/fifo_buffer.c src/util/fifo_buffer.h \
src/util/FifoBuffer.hxx \
+ src/util/DynamicFifoBuffer.hxx \
+ src/util/ConstBuffer.hxx \
src/util/WritableBuffer.hxx \
- src/util/growing_fifo.c src/util/growing_fifo.h \
src/util/LazyRandomEngine.cxx src/util/LazyRandomEngine.hxx \
src/util/SliceBuffer.hxx \
src/util/HugeAllocator.cxx src/util/HugeAllocator.hxx \
src/util/PeakBuffer.cxx src/util/PeakBuffer.hxx \
+ src/util/OptionParser.cxx OptionParser.hxx \
+ src/util/OptionDef.hxx \
src/util/list.h \
src/util/list_sort.c src/util/list_sort.h \
src/util/ByteReverse.cxx src/util/ByteReverse.hxx \
@@ -297,12 +304,18 @@ libsystem_a_SOURCES = \
src/system/EventFD.cxx src/system/EventFD.hxx \
src/system/SignalFD.cxx src/system/SignalFD.hxx \
src/system/EPollFD.cxx src/system/EPollFD.hxx \
+ src/system/PeriodClock.hxx \
src/system/Clock.cxx src/system/Clock.hxx
# Event loop library
libevent_a_SOURCES = \
src/event/WakeFD.hxx \
+ src/event/PollGroup.hxx \
+ src/event/PollGroupEPoll.hxx \
+ src/event/PollGroupPoll.hxx src/event/PollGroupPoll.cxx \
+ src/event/PollGroupWinSelect.hxx src/event/PollGroupWinSelect.cxx \
+ src/event/PollResultGeneric.hxx \
src/event/SignalMonitor.hxx src/event/SignalMonitor.cxx \
src/event/TimeoutMonitor.hxx src/event/TimeoutMonitor.cxx \
src/event/IdleMonitor.hxx src/event/IdleMonitor.cxx \
@@ -318,32 +331,45 @@ libevent_a_SOURCES = \
# PCM library
libpcm_a_SOURCES = \
+ src/pcm/Domain.cxx src/pcm/Domain.hxx \
+ src/pcm/Traits.hxx \
src/pcm/PcmBuffer.cxx src/pcm/PcmBuffer.hxx \
src/pcm/PcmExport.cxx src/pcm/PcmExport.hxx \
src/pcm/PcmConvert.cxx src/pcm/PcmConvert.hxx \
src/pcm/dsd2pcm/dsd2pcm.c src/pcm/dsd2pcm/dsd2pcm.h \
src/pcm/PcmDsd.cxx src/pcm/PcmDsd.hxx \
src/pcm/PcmDsdUsb.cxx src/pcm/PcmDsdUsb.hxx \
- src/pcm/PcmVolume.cxx src/pcm/PcmVolume.hxx \
+ src/pcm/Volume.cxx src/pcm/Volume.hxx \
src/pcm/PcmMix.cxx src/pcm/PcmMix.hxx \
src/pcm/PcmChannels.cxx src/pcm/PcmChannels.hxx \
src/pcm/PcmPack.cxx src/pcm/PcmPack.hxx \
src/pcm/PcmFormat.cxx src/pcm/PcmFormat.hxx \
- src/pcm/PcmResample.cxx src/pcm/PcmResample.hxx \
- src/pcm/PcmResampleFallback.cxx \
- src/pcm/PcmResampleInternal.hxx \
+ src/pcm/FormatConverter.cxx src/pcm/FormatConverter.hxx \
+ src/pcm/ChannelsConverter.cxx src/pcm/ChannelsConverter.hxx \
+ src/pcm/Resampler.hxx \
+ src/pcm/GlueResampler.cxx src/pcm/GlueResampler.hxx \
+ src/pcm/FallbackResampler.cxx src/pcm/FallbackResampler.hxx \
+ src/pcm/ConfiguredResampler.cxx src/pcm/ConfiguredResampler.hxx \
src/pcm/PcmDither.cxx src/pcm/PcmDither.hxx \
src/pcm/PcmPrng.hxx \
src/pcm/PcmUtils.hxx
libpcm_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(SOXR_CFLAGS) \
$(SAMPLERATE_CFLAGS)
PCM_LIBS = \
libpcm.a \
+ $(SOXR_LIBS) \
$(SAMPLERATE_LIBS)
if HAVE_LIBSAMPLERATE
-libpcm_a_SOURCES += src/pcm/PcmResampleLibsamplerate.cxx
+libpcm_a_SOURCES += \
+ src/pcm/LibsamplerateResampler.cxx src/pcm/LibsamplerateResampler.hxx
+endif
+
+if HAVE_SOXR
+libpcm_a_SOURCES += \
+ src/pcm/SoxrResampler.cxx src/pcm/SoxrResampler.hxx
endif
# File system library
@@ -356,7 +382,9 @@ libfs_a_SOURCES = \
src/fs/Charset.cxx src/fs/Charset.hxx \
src/fs/Path.cxx src/fs/Path.hxx \
src/fs/AllocatedPath.cxx src/fs/AllocatedPath.hxx \
+ src/fs/TextFile.cxx src/fs/TextFile.hxx \
src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
+ src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/DirectoryReader.hxx
# database plugins
@@ -776,6 +804,14 @@ INPUT_LIBS = \
$(DESPOTIFY_LIBS) \
$(MMS_LIBS)
+if HAVE_ALSA
+libinput_a_SOURCES += \
+ src/input/AlsaInputPlugin.cxx \
+ src/input/AlsaInputPlugin.hxx
+INPUT_LIBS += $(ALSA_LIBS)
+endif
+
+
if ENABLE_CURL
libinput_a_SOURCES += \
src/input/CurlInputPlugin.cxx src/input/CurlInputPlugin.hxx \
@@ -963,14 +999,6 @@ libplaylist_plugins_a_SOURCES = \
src/playlist/ExtM3uPlaylistPlugin.hxx \
src/playlist/M3uPlaylistPlugin.cxx \
src/playlist/M3uPlaylistPlugin.hxx \
- src/playlist/PlsPlaylistPlugin.cxx \
- src/playlist/PlsPlaylistPlugin.hxx \
- src/playlist/XspfPlaylistPlugin.cxx \
- src/playlist/XspfPlaylistPlugin.hxx \
- src/playlist/AsxPlaylistPlugin.cxx \
- src/playlist/AsxPlaylistPlugin.hxx \
- src/playlist/RssPlaylistPlugin.cxx \
- src/playlist/RssPlaylistPlugin.hxx \
src/playlist/CuePlaylistPlugin.cxx \
src/playlist/CuePlaylistPlugin.hxx \
src/playlist/EmbeddedCuePlaylistPlugin.cxx \
@@ -997,6 +1025,18 @@ libplaylist_plugins_a_SOURCES += \
PLAYLIST_LIBS += $(YAJL_LIBS)
endif
+if HAVE_GLIB
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/PlsPlaylistPlugin.cxx \
+ src/playlist/PlsPlaylistPlugin.hxx \
+ src/playlist/XspfPlaylistPlugin.cxx \
+ src/playlist/XspfPlaylistPlugin.hxx \
+ src/playlist/AsxPlaylistPlugin.cxx \
+ src/playlist/AsxPlaylistPlugin.hxx \
+ src/playlist/RssPlaylistPlugin.cxx \
+ src/playlist/RssPlaylistPlugin.hxx
+endif
+
#
# Filter plugins
#
@@ -1110,7 +1150,7 @@ test_read_conf_LDADD = \
libfs.a \
$(GLIB_LIBS)
test_read_conf_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
test/read_conf.cxx
test_run_resolver_LDADD = \
@@ -1118,7 +1158,7 @@ test_run_resolver_LDADD = \
libutil.a \
$(GLIB_LIBS)
test_run_resolver_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
test/run_resolver.cxx
test_DumpDatabase_LDADD = \
@@ -1131,7 +1171,7 @@ test_DumpDatabase_LDADD = \
$(GLIB_LIBS)
test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/protocol/Ack.cxx \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/DatabaseError.cxx \
src/DatabaseRegistry.cxx \
src/DatabaseSelection.cxx \
@@ -1140,8 +1180,7 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/DatabaseLock.cxx src/DatabaseSave.cxx \
src/Song.cxx src/SongSave.cxx src/SongSort.cxx \
src/TagSave.cxx \
- src/SongFilter.cxx \
- src/TextFile.cxx
+ src/SongFilter.cxx
test_run_input_LDADD = \
$(INPUT_LIBS) \
@@ -1156,7 +1195,7 @@ test_run_input_LDADD = \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/TagSave.cxx
@@ -1174,7 +1213,7 @@ test_visit_archive_LDADD = \
libfs.a \
$(GLIB_LIBS)
test_visit_archive_SOURCES = test/visit_archive.cxx \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/InputStream.cxx
@@ -1197,7 +1236,7 @@ test_dump_text_file_LDADD = \
$(GLIB_LIBS)
test_dump_text_file_SOURCES = test/dump_text_file.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/TextInputStream.cxx
@@ -1217,8 +1256,9 @@ test_dump_playlist_LDADD = \
libpcm.a \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.cxx \
+ test/FakeDecoderAPI.cxx \
$(DECODER_SRC) \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/Song.cxx src/TagSave.cxx \
src/TagFile.cxx \
@@ -1247,7 +1287,7 @@ test_run_decoder_LDADD = \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/ReplayGainInfo.cxx \
src/AudioFormat.cxx src/CheckAudioFormat.cxx \
@@ -1270,7 +1310,8 @@ test_read_tags_LDADD = \
libutil.a \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.cxx \
- src/Log.cxx \
+ test/FakeDecoderAPI.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/ReplayGainInfo.cxx \
src/CheckAudioFormat.cxx \
@@ -1282,7 +1323,7 @@ test_dump_rva2_LDADD = \
libutil.a \
$(GLIB_LIBS)
test_dump_rva2_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
test/dump_rva2.cxx
endif
@@ -1296,7 +1337,7 @@ test_run_filter_LDADD = \
test_run_filter_SOURCES = test/run_filter.cxx \
test/FakeReplayGainConfig.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/FilterPlugin.cxx src/FilterRegistry.cxx \
src/CheckAudioFormat.cxx \
src/AudioFormat.cxx \
@@ -1316,7 +1357,7 @@ if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/CheckAudioFormat.cxx \
src/AudioFormat.cxx \
src/AudioParser.cxx
@@ -1336,7 +1377,7 @@ if ENABLE_VORBIS_ENCODER
noinst_PROGRAMS += test/test_vorbis_encoder
test_test_vorbis_encoder_SOURCES = test/test_vorbis_encoder.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/CheckAudioFormat.cxx \
src/AudioFormat.cxx \
src/AudioParser.cxx \
@@ -1356,7 +1397,7 @@ endif
test_software_volume_SOURCES = test/software_volume.cxx \
test/stdbin.h \
- src/CheckAudioFormat.cxx \
+ src/AudioFormat.cxx src/CheckAudioFormat.cxx \
src/AudioParser.cxx
test_software_volume_LDADD = \
$(PCM_LIBS) \
@@ -1364,7 +1405,7 @@ test_software_volume_LDADD = \
$(GLIB_LIBS)
test_run_avahi_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/ZeroconfAvahi.cxx src/AvahiPoll.cxx \
test/ShutdownHandler.cxx test/ShutdownHandler.hxx \
test/run_avahi.cxx
@@ -1386,7 +1427,7 @@ test_run_normalize_LDADD = \
$(GLIB_LIBS)
test_run_convert_SOURCES = test/run_convert.cxx \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/AudioFormat.cxx \
src/CheckAudioFormat.cxx \
src/AudioParser.cxx
@@ -1412,7 +1453,7 @@ test_run_output_LDADD = $(MPD_LIBS) \
test_run_output_SOURCES = test/run_output.cxx \
test/FakeReplayGainConfig.cxx \
test/stdbin.h \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/CheckAudioFormat.cxx \
src/AudioFormat.cxx \
@@ -1440,9 +1481,10 @@ test_read_mixer_LDADD = \
libfs.a \
$(GLIB_LIBS)
test_read_mixer_SOURCES = test/read_mixer.cxx \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/MixerControl.cxx \
src/FilterPlugin.cxx \
+ src/AudioFormat.cxx \
src/filter/VolumeFilterPlugin.cxx
if ENABLE_BZIP2_TEST
@@ -1461,7 +1503,7 @@ if ENABLE_INOTIFY
noinst_PROGRAMS += test/run_inotify
test_run_inotify_SOURCES = test/run_inotify.cxx \
test/ShutdownHandler.cxx test/ShutdownHandler.hxx \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
src/InotifyDomain.cxx \
src/InotifySource.cxx
test_run_inotify_LDADD = \
@@ -1488,7 +1530,7 @@ test_test_byte_reverse_LDADD = \
$(CPPUNIT_LIBS)
test_test_mixramp_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
test/test_mixramp.cxx
test_test_mixramp_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
test_test_mixramp_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
@@ -1497,6 +1539,7 @@ test_test_mixramp_LDADD = \
$(CPPUNIT_LIBS)
test_test_pcm_SOURCES = \
+ src/AudioFormat.cxx \
test/test_pcm_util.hxx \
test/test_pcm_dither.cxx \
test/test_pcm_pack.cxx \
@@ -1515,7 +1558,7 @@ test_test_pcm_LDADD = \
$(GLIB_LIBS)
test_test_archive_SOURCES = \
- src/Log.cxx \
+ src/Log.cxx src/LogBackend.cxx \
test/test_archive.cxx
test_test_archive_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
test_test_archive_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations