aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am114
1 files changed, 103 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index aadeb2508..5a6a8dafa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,10 @@
ACLOCAL_AMFLAGS = -I m4
-AUTOMAKE_OPTIONS = foreign 1.9 dist-bzip2
+AUTOMAKE_OPTIONS = foreign 1.10 dist-bzip2
AM_CPPFLAGS = -I$(srcdir)/src $(GLIB_CFLAGS)
+AM_CPPFLAGS += -DSYSTEM_CONFIG_FILE_LOCATION='"$(sysconfdir)/mpd.conf"'
+
bin_PROGRAMS = src/mpd
src_mpd_CFLAGS = $(AM_CFLAGS) $(MPD_CFLAGS)
@@ -42,7 +44,12 @@ mpd_headers = \
src/output_state.h \
src/output_print.h \
src/output_command.h \
- src/buffer2array.h \
+ src/filter_internal.h \
+ src/filter_plugin.h \
+ src/filter_registry.h \
+ src/filter/chain_filter_plugin.h \
+ src/filter/convert_filter_plugin.h \
+ src/filter/volume_filter_plugin.h \
src/command.h \
src/idle.h \
src/cmdline.h \
@@ -80,6 +87,7 @@ mpd_headers = \
src/icy_server.h \
src/icy_metadata.h \
src/client.h \
+ src/client_internal.h \
src/listen.h \
src/log.h \
src/ls.h \
@@ -90,6 +98,8 @@ mpd_headers = \
src/mixer_list.h \
src/event_pipe.h \
src/mixer_plugin.h \
+ src/mixer_type.h \
+ src/mixer/software_mixer_plugin.h \
src/daemon.h \
src/normalize.h \
src/compress.h \
@@ -106,6 +116,7 @@ mpd_headers = \
src/pcm_convert.h \
src/pcm_volume.h \
src/pcm_mix.h \
+ src/pcm_byteswap.h \
src/pcm_channels.h \
src/pcm_format.h \
src/pcm_resample.h \
@@ -145,6 +156,7 @@ mpd_headers = \
src/tag_id3.h \
src/tag_print.h \
src/tag_save.h \
+ src/tokenizer.h \
src/strset.h \
src/uri.h \
src/utils.h \
@@ -168,10 +180,10 @@ src_mpd_SOURCES = \
$(ENCODER_SRC) \
$(OUTPUT_API_SRC) $(OUTPUT_SRC) \
$(MIXER_API_SRC) $(MIXER_SRC) \
+ $(FILTER_SRC) \
src/notify.c \
src/audio.c \
src/audio_parser.c \
- src/buffer2array.c \
src/command.c \
src/idle.c \
src/cmdline.c \
@@ -188,8 +200,19 @@ src_mpd_SOURCES = \
src/database.c \
src/dirvec.c \
src/fifo_buffer.c \
+ src/filter_plugin.c \
+ src/filter_registry.c \
src/update.c \
src/client.c \
+ src/client_event.c \
+ src/client_expire.c \
+ src/client_global.c \
+ src/client_idle.c \
+ src/client_list.c \
+ src/client_new.c \
+ src/client_process.c \
+ src/client_read.c \
+ src/client_write.c \
src/listen.c \
src/log.c \
src/ls.c \
@@ -207,6 +230,7 @@ src_mpd_SOURCES = \
src/pcm_convert.c \
src/pcm_volume.c \
src/pcm_mix.c \
+ src/pcm_byteswap.c \
src/pcm_channels.c \
src/pcm_format.c \
src/pcm_resample.c \
@@ -238,6 +262,7 @@ src_mpd_SOURCES = \
src/tag_pool.c \
src/tag_print.c \
src/tag_save.c \
+ src/tokenizer.c \
src/strset.c \
src/uri.c \
src/utils.c \
@@ -314,25 +339,31 @@ endif
DECODER_CFLAGS = \
$(VORBIS_CFLAGS) $(TREMOR_CFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS)) \
+ $(SNDFILE_CFLAGS) \
$(AUDIOFILE_CFLAGS) \
$(LIBMIKMOD_CFLAGS) \
$(MODPLUG_CFLAGS) \
$(SIDPLAY_CFLAGS) \
$(FLUIDSYNTH_CFLAGS) \
$(WILDMIDI_CFLAGS) \
+ $(WAVPACK_CFLAGS) \
$(MAD_CFLAGS) \
+ $(MPG123_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(CUE_CFLAGS)
DECODER_LIBS = \
$(VORBIS_LIBS) $(TREMOR_LIBS) \
$(FLAC_LIBS) \
+ $(SNDFILE_LIBS) \
$(AUDIOFILE_LIBS) $(LIBMIKMOD_LIBS) \
$(MODPLUG_LIBS) \
$(SIDPLAY_LIBS) \
$(FLUIDSYNTH_LIBS) \
$(WILDMIDI_LIBS) \
+ $(WAVPACK_LIBS) \
$(MAD_LIBS) \
+ $(MPG123_LIBS) \
$(MP4FF_LIBS) \
$(FFMPEG_LIBS) \
$(CUE_LIBS)
@@ -345,6 +376,10 @@ if HAVE_MAD
DECODER_SRC += src/decoder/mad_plugin.c
endif
+if HAVE_MPG123
+DECODER_SRC += src/decoder/mpg123_decoder_plugin.c
+endif
+
if HAVE_MPCDEC
DECODER_SRC += src/decoder/mpcdec_plugin.c
endif
@@ -409,14 +444,20 @@ if HAVE_FFMPEG
DECODER_SRC += src/decoder/ffmpeg_plugin.c
endif
+if ENABLE_SNDFILE
+DECODER_SRC += src/decoder/sndfile_decoder_plugin.c
+endif
+
# encoder plugins
ENCODER_CFLAGS = \
$(LAME_CFLAGS) \
+ $(TWOLAME_CFLAGS) \
$(VORBISENC_CFLAGS)
ENCODER_LIBS = \
$(LAME_LIBS) \
+ $(TWOLAME_LIBS) \
$(VORBISENC_LIBS)
ENCODER_SRC =
@@ -431,6 +472,10 @@ endif
if ENABLE_LAME_ENCODER
ENCODER_SRC += src/encoder/lame_encoder.c
endif
+
+if ENABLE_TWOLAME_ENCODER
+ENCODER_SRC += src/encoder/twolame_encoder.c
+endif
endif
@@ -508,10 +553,12 @@ OUTPUT_SRC = \
MIXER_API_SRC = \
src/mixer_control.c \
+ src/mixer_type.c \
src/mixer_all.c \
src/mixer_api.c
-MIXER_SRC =
+MIXER_SRC = \
+ src/mixer/software_mixer_plugin.c
if HAVE_ALSA
OUTPUT_SRC += src/output/alsa_plugin.c
@@ -543,6 +590,10 @@ OUTPUT_SRC += src/output/oss_plugin.c
MIXER_SRC += src/mixer/oss_mixer.c
endif
+if HAVE_OPENAL
+OUTPUT_SRC += src/output/openal_plugin.c
+endif
+
if HAVE_OSX
OUTPUT_SRC += src/output/osx_plugin.c
endif
@@ -556,6 +607,10 @@ if HAVE_SHOUT
OUTPUT_SRC += src/output/shout_plugin.c
endif
+if ENABLE_RECORDER_OUTPUT
+OUTPUT_SRC += src/output/recorder_output_plugin.c
+endif
+
if ENABLE_HTTPD_OUTPUT
OUTPUT_SRC += \
src/icy_server.c \
@@ -569,6 +624,17 @@ endif
#
+# Filter plugins
+#
+
+FILTER_SRC = \
+ src/filter/null_filter_plugin.c \
+ src/filter/chain_filter_plugin.c \
+ src/filter/convert_filter_plugin.c \
+ src/filter/volume_filter_plugin.c
+
+
+#
# Sparse code analysis
#
# sparse is a semantic parser
@@ -599,6 +665,7 @@ noinst_PROGRAMS = \
test/run_input \
test/run_decoder \
test/read_tags \
+ test/run_filter \
test/run_output \
test/read_mixer \
test/software_volume
@@ -608,7 +675,7 @@ test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
test_read_conf_LDADD = $(MPD_LIBS) \
$(GLIB_LIBS)
test_read_conf_SOURCES = test/read_conf.c \
- src/conf.c src/buffer2array.c src/utils.c
+ src/conf.c src/tokenizer.c src/utils.c
test_run_input_CPPFLAGS = $(AM_CPPFLAGS) \
$(ARCHIVE_CFLAGS) \
@@ -618,7 +685,7 @@ test_run_input_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.c \
- src/conf.c src/buffer2array.c src/utils.c \
+ src/conf.c src/tokenizer.c src/utils.c \
src/tag.c src/tag_pool.c src/tag_save.c \
$(ARCHIVE_SRC) \
$(INPUT_SRC)
@@ -633,7 +700,7 @@ test_run_decoder_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) $(DECODER_LIBS) \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.c \
- src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/log.c \
src/tag.c src/tag_pool.c \
src/replay_gain.c \
src/uri.c \
@@ -652,7 +719,7 @@ test_read_tags_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) $(DECODER_LIBS) \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.c \
- src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/log.c \
src/tag.c src/tag_pool.c \
src/replay_gain.c \
src/uri.c \
@@ -661,10 +728,28 @@ test_read_tags_SOURCES = test/read_tags.c \
$(TAG_SRC) \
$(DECODER_SRC)
+test_run_filter_CPPFLAGS = $(AM_CPPFLAGS)
+test_run_filter_LDADD = $(MPD_LIBS) \
+ $(SAMPLERATE_LIBS) \
+ $(GLIB_LIBS)
+test_run_filter_SOURCES = test/run_filter.c \
+ src/filter_plugin.c \
+ src/filter_registry.c \
+ src/conf.c src/tokenizer.c src/utils.c \
+ src/pcm_volume.c src/pcm_convert.c src/pcm_byteswap.c \
+ src/pcm_format.c src/pcm_channels.c src/pcm_dither.c \
+ src/pcm_resample.c src/pcm_resample_fallback.c \
+ src/audio_parser.c \
+ $(FILTER_SRC)
+
+if HAVE_LIBSAMPLERATE
+test_run_filter_SOURCES += src/pcm_resample_libsamplerate.c
+endif
+
if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.c \
- src/conf.c src/buffer2array.c \
+ src/conf.c src/tokenizer.c \
src/utils.c \
src/tag.c src/tag_pool.c \
src/audio_parser.c \
@@ -688,7 +773,7 @@ test_run_output_LDADD = $(MPD_LIBS) \
$(OUTPUT_LIBS) \
$(GLIB_LIBS)
test_run_output_SOURCES = test/run_output.c \
- src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/log.c \
src/audio_parser.c \
src/timer.c \
src/tag.c src/tag_pool.c \
@@ -699,7 +784,12 @@ test_run_output_SOURCES = test/run_output.c \
$(ENCODER_SRC) \
src/mixer_api.c \
src/mixer_control.c \
+ src/mixer_type.c \
$(MIXER_SRC) \
+ src/filter_plugin.c src/filter/chain_filter_plugin.c \
+ src/filter/convert_filter_plugin.c \
+ src/filter/volume_filter_plugin.c \
+ src/pcm_volume.c \
$(OUTPUT_SRC)
test_read_mixer_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -708,8 +798,10 @@ test_read_mixer_LDADD = $(MPD_LIBS) \
$(OUTPUT_LIBS) \
$(GLIB_LIBS)
test_read_mixer_SOURCES = test/read_mixer.c \
- src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/log.c \
src/mixer_control.c src/mixer_api.c \
+ src/filter_plugin.c \
+ src/filter/volume_filter_plugin.c \
$(MIXER_SRC)
endif