aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fa2efb7d6..d25703b1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -676,6 +676,14 @@ install-data-local: doc/api/html/index.html
doc/api/html/*.png doc/api/html/*.gif \
$(DESTDIR)$(docdir)/api/html
+upload: $(DOCBOOK_HTML) doc/api/html/index.html
+ rsync -vpruz --delete doc/ cirrus@www.musicpd.org:/var/www/musicpd.org/www/doc/ \
+ --chmod=Dug+rwx,Do+rx,Fug+rw,Fo+r \
+ --include=protocol --include=protocol/** \
+ --include=user --include=user/** \
+ --include=api --include=api/** \
+ --exclude=*
+
endif