aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d9f32f468..c07493f7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -797,11 +797,15 @@ noinst_PROGRAMS = \
test/read_tags \
test/run_filter \
test/run_output \
- test/read_mixer \
test/run_convert \
test/run_normalize \
test/software_volume
+if HAVE_ALSA
+# this debug program is still ALSA specific
+noinst_PROGRAMS += test/read_mixer
+endif
+
test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
$(GLIB_CFLAGS)
test_read_conf_LDADD = $(MPD_LIBS) \