aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dea7bdb56..48a143f39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1058,6 +1058,7 @@ if ENABLE_TEST
C_TESTS = \
test/test_util \
test/test_byte_reverse \
+ test/test_mixramp \
test/test_pcm \
test/test_queue_priority
@@ -1483,6 +1484,15 @@ test_test_byte_reverse_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_test_mixramp_SOURCES = \
+ src/Log.cxx \
+ test/test_mixramp.cxx
+test_test_mixramp_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_mixramp_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_mixramp_LDADD = \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_pcm_SOURCES = \
test/test_pcm_util.hxx \
test/test_pcm_dither.cxx \