aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 469ac5330..f5fb2148f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -684,6 +684,7 @@ libencoder_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(LAME_CFLAGS) \
$(TWOLAME_CFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS)) \
+ $(OPUS_CFLAGS) \
$(VORBISENC_CFLAGS)
ENCODER_LIBS = \
@@ -691,6 +692,7 @@ ENCODER_LIBS = \
$(LAME_LIBS) \
$(TWOLAME_LIBS) \
$(FLAC_LIBS) \
+ $(OPUS_LIBS) \
$(VORBISENC_LIBS)
libencoder_plugins_a_SOURCES =
@@ -708,6 +710,12 @@ libencoder_plugins_a_SOURCES += \
src/encoder/VorbisEncoderPlugin.hxx
endif
+if HAVE_OPUS
+libencoder_plugins_a_SOURCES += \
+ src/encoder/OpusEncoderPlugin.cxx \
+ src/encoder/OpusEncoderPlugin.hxx
+endif
+
if ENABLE_LAME_ENCODER
libencoder_plugins_a_SOURCES += src/encoder/lame_encoder.c
endif