aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b3f62b6f7..1bacdcdbd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1056,6 +1056,7 @@ sparse-check:
if ENABLE_TEST
C_TESTS = \
+ test/test_util \
test/test_byte_reverse \
test/test_pcm \
test/test_queue_priority
@@ -1466,6 +1467,15 @@ test_run_inotify_LDADD = \
$(GLIB_LIBS)
endif
+test_test_util_SOURCES = \
+ test/test_util.cxx
+test_test_util_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_util_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_util_LDADD = \
+ libutil.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_byte_reverse_SOURCES = \
test/test_byte_reverse.cxx
test_test_byte_reverse_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0