aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am270
1 files changed, 185 insertions, 85 deletions
diff --git a/Makefile.am b/Makefile.am
index 89819de36..c6bcfa1a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ AM_CPPFLAGS += -I$(srcdir)/src $(GLIB_CFLAGS) $(BOOST_CPPFLAGS)
AM_CPPFLAGS += -DSYSTEM_CONFIG_FILE_LOCATION='"$(sysconfdir)/mpd.conf"'
+APK_NAME = mpd
if ANDROID
else
bin_PROGRAMS = src/mpd
@@ -14,6 +15,7 @@ noinst_LIBRARIES = \
libmpd.a \
libutil.a \
libthread.a \
+ libnet.a \
libsystem.a \
libevent.a \
libicu.a \
@@ -46,18 +48,19 @@ src_mpd_LDADD = \
$(DECODER_LIBS) \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
- $(TAG_LIBS) \
$(OUTPUT_LIBS) \
+ $(TAG_LIBS) \
$(FILTER_LIBS) \
$(ENCODER_LIBS) \
$(MIXER_LIBS) \
libconf.a \
libevent.a \
libthread.a \
+ libnet.a \
+ $(FS_LIBS) \
libsystem.a \
- $(ICU_LDADD) \
libutil.a \
- $(FS_LIBS) \
+ $(ICU_LDADD) \
$(SYSTEMD_DAEMON_LIBS) \
$(GLIB_LIBS)
@@ -184,9 +187,14 @@ if ANDROID
else
libmpd_a_SOURCES += \
src/unix/SignalHandlers.cxx src/unix/SignalHandlers.hxx \
- src/unix/Daemon.cxx src/unix/Daemon.hxx \
- src/unix/PidFile.hxx \
src/CommandLine.cxx src/CommandLine.hxx
+
+if ENABLE_DAEMON
+libmpd_a_SOURCES += \
+ src/unix/Daemon.cxx src/unix/Daemon.hxx \
+ src/unix/PidFile.hxx
+endif
+
endif
if ENABLE_DATABASE
@@ -266,7 +274,7 @@ libmain_a_CPPFLAGS = $(AM_CPPFLAGS) -Iandroid/build/include
src_mpd_LDADD += libandroid.a libjava.a
-all-local: android/build/bin/Main-debug.apk
+all-local: android/build/bin/$(APK_NAME)-debug.apk
clean-local:
rm -rf android/build
@@ -278,8 +286,8 @@ android/build/build.xml: android/AndroidManifest.xml
mkdir -p android/build/include android/build/res android/build/src/org
ln -s $(abs_srcdir)/android/AndroidManifest.xml $(abs_srcdir)/android/custom_rules.xml android/build
ln -s $(abs_srcdir)/android/src android/build/src/org/musicpd
- ln -s $(abs_srcdir)/android/res/values android/build/res
- $(ANDROID_SDK)/tools/android update project --path android/build --target android-17
+ ln -s $(abs_srcdir)/android/res/values $(abs_srcdir)/android/res/layout android/build/res
+ $(ANDROID_SDK)/tools/android update project --path android/build --target android-17 --name $(APK_NAME)
android/build/bin/classes/org/musicpd/Bridge.class: android/src/Bridge.java android/build/build.xml android/build/res/drawable/icon.png
cd android/build && ant compile-jni-classes
@@ -303,18 +311,18 @@ APK_DEPS = android/build/res/drawable/icon.png \
$(wildcard $(srcdir)/android/src/*.java) \
android/build/build.xml
-android/build/bin/Main-debug.apk: $(APK_DEPS)
+android/build/bin/$(APK_NAME)-debug.apk: $(APK_DEPS)
cd android/build && ant nodeps debug
-android/build/bin/Main-release-unsigned.apk: $(APK_DEPS)
+android/build/bin/$(APK_NAME)-release-unsigned.apk: $(APK_DEPS)
cd android/build && ant nodeps release
-android/build/bin/Main-release-unaligned.apk: android/build/bin/Main-release-unsigned.apk
+android/build/bin/$(APK_NAME)-release-unaligned.apk: android/build/bin/$(APK_NAME)-release-unsigned.apk
jarsigner -digestalg SHA1 -sigalg MD5withRSA -storepass:env ANDROID_KEYSTORE_PASS -keystore $(ANDROID_KEYSTORE) -signedjar $@ $< $(ANDROID_KEY_ALIAS)
ANDROID_SDK_BUILD_TOOLS_VERSION = 20.0.0
-android/build/bin/Main.apk: android/build/bin/Main-release-unaligned.apk
+android/build/bin/$(APK_NAME).apk: android/build/bin/$(APK_NAME)-release-unaligned.apk
$(ANDROID_SDK)/build-tools/$(ANDROID_SDK_BUILD_TOOLS_VERSION)/zipalign -f 4 $< $@
endif
@@ -323,14 +331,14 @@ endif
# Windows resource file
#
-src/win32/mpd_win32_rc.$(OBJEXT): src/win32/mpd_win32_rc.rc
+win32/res/mpd.$(OBJEXT): %.$(OBJEXT): %.rc
$(WINDRES) -i $< -o $@
if HAVE_WINDOWS
-noinst_DATA = src/win32/mpd_win32_rc.rc
+noinst_DATA = win32/res/mpd.rc
-EXTRA_src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
-src_mpd_LDFLAGS = -Wl,src/win32/mpd_win32_rc.$(OBJEXT)
+EXTRA_src_mpd_DEPENDENCIES = win32/res/mpd.$(OBJEXT)
+src_mpd_LDFLAGS = -Wl,win32/res/mpd.$(OBJEXT)
endif
if ENABLE_DATABASE
@@ -346,6 +354,9 @@ endif
if ENABLE_SQLITE
libmpd_a_SOURCES += \
src/command/StickerCommands.cxx src/command/StickerCommands.hxx \
+ src/lib/sqlite/Domain.cxx src/lib/sqlite/Domain.hxx \
+ src/lib/sqlite/Util.hxx \
+ src/sticker/Match.hxx \
src/sticker/StickerDatabase.cxx src/sticker/StickerDatabase.hxx \
src/sticker/StickerPrint.cxx src/sticker/StickerPrint.hxx \
src/sticker/SongSticker.cxx src/sticker/SongSticker.hxx
@@ -367,6 +378,10 @@ libutil_a_SOURCES = \
src/util/CharUtil.hxx \
src/util/NumberParser.hxx \
src/util/StringUtil.cxx src/util/StringUtil.hxx \
+ src/util/WStringUtil.cxx src/util/WStringUtil.hxx \
+ src/util/StringAPI.hxx \
+ src/util/WStringAPI.hxx \
+ src/util/DivideString.cxx src/util/DivideString.hxx \
src/util/SplitString.cxx src/util/SplitString.hxx \
src/util/FormatString.cxx src/util/FormatString.hxx \
src/util/Tokenizer.cxx src/util/Tokenizer.hxx \
@@ -387,6 +402,7 @@ libutil_a_SOURCES = \
src/util/OptionParser.cxx src/util/OptionParser.hxx \
src/util/OptionDef.hxx \
src/util/ByteReverse.cxx src/util/ByteReverse.hxx \
+ src/util/format.c src/util/format.h \
src/util/bit_reverse.c src/util/bit_reverse.h
# Multi-threading library
@@ -404,15 +420,22 @@ libthread_a_SOURCES = \
src/thread/Thread.cxx src/thread/Thread.hxx \
src/thread/Id.hxx
+# Networking library
+
+libnet_a_SOURCES = \
+ src/net/Resolver.cxx src/net/Resolver.hxx \
+ src/net/StaticSocketAddress.cxx src/net/StaticSocketAddress.hxx \
+ src/net/SocketAddress.cxx src/net/SocketAddress.hxx \
+ src/net/SocketUtil.cxx src/net/SocketUtil.hxx \
+ src/net/SocketError.cxx src/net/SocketError.hxx
+
# System library
libsystem_a_SOURCES = \
src/system/ByteOrder.hxx \
src/system/FatalError.cxx src/system/FatalError.hxx \
+ src/system/FileDescriptor.cxx src/system/FileDescriptor.hxx \
src/system/fd_util.c src/system/fd_util.h \
- src/system/SocketUtil.cxx src/system/SocketUtil.hxx \
- src/system/SocketError.cxx src/system/SocketError.hxx \
- src/system/Resolver.cxx src/system/Resolver.hxx \
src/system/EventPipe.cxx src/system/EventPipe.hxx \
src/system/EventFD.cxx src/system/EventFD.hxx \
src/system/SignalFD.cxx src/system/SignalFD.hxx \
@@ -445,10 +468,12 @@ libevent_a_SOURCES = \
libicu_a_SOURCES = \
src/lib/icu/Collate.cxx src/lib/icu/Collate.hxx \
+ src/lib/icu/Converter.cxx src/lib/icu/Converter.hxx \
src/lib/icu/Error.cxx src/lib/icu/Error.hxx
if HAVE_ICU
libicu_a_SOURCES += \
+ src/lib/icu/Util.cxx src/lib/icu/Util.hxx \
src/lib/icu/Init.cxx src/lib/icu/Init.hxx
endif
@@ -457,6 +482,11 @@ libicu_a_CPPFLAGS = $(AM_CPPFLAGS) \
ICU_LDADD = libicu.a $(ICU_LIBS)
+if HAVE_ICU
+else
+ICU_LDADD += $(GLIB_LIBS)
+endif
+
# PCM library
libpcm_a_SOURCES = \
@@ -485,12 +515,12 @@ libpcm_a_SOURCES = \
src/pcm/PcmUtils.hxx
libpcm_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(SOXR_CFLAGS) \
- $(SAMPLERATE_CFLAGS)
+ $(LIBSAMPLERATE_CFLAGS)
PCM_LIBS = \
libpcm.a \
$(SOXR_LIBS) \
- $(SAMPLERATE_LIBS)
+ $(LIBSAMPLERATE_LIBS)
if ENABLE_DSD
libpcm_a_SOURCES += \
@@ -498,12 +528,12 @@ libpcm_a_SOURCES += \
src/pcm/dsd2pcm/dsd2pcm.c src/pcm/dsd2pcm/dsd2pcm.h
endif
-if HAVE_LIBSAMPLERATE
+if ENABLE_LIBSAMPLERATE
libpcm_a_SOURCES += \
src/pcm/LibsamplerateResampler.cxx src/pcm/LibsamplerateResampler.hxx
endif
-if HAVE_SOXR
+if ENABLE_SOXR
libpcm_a_SOURCES += \
src/pcm/SoxrResampler.cxx src/pcm/SoxrResampler.hxx
endif
@@ -527,15 +557,17 @@ libfs_a_SOURCES = \
src/fs/Traits.cxx src/fs/Traits.hxx \
src/fs/Config.cxx src/fs/Config.hxx \
src/fs/Charset.cxx src/fs/Charset.hxx \
- src/fs/Path.cxx src/fs/Path.hxx \
+ src/fs/Path.cxx src/fs/Path2.cxx src/fs/Path.hxx \
src/fs/AllocatedPath.cxx src/fs/AllocatedPath.hxx \
+ src/fs/NarrowPath.hxx \
src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
+ src/fs/FileInfo.hxx \
src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/CheckFile.cxx src/fs/CheckFile.hxx \
src/fs/DirectoryReader.hxx
libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
-if HAVE_ZLIB
+if ENABLE_ZLIB
libfs_a_SOURCES += \
src/lib/zlib/Domain.cxx src/lib/zlib/Domain.hxx \
src/fs/io/GunzipReader.cxx src/fs/io/GunzipReader.hxx \
@@ -631,7 +663,7 @@ NEIGHBOR_LIBS = \
$(SMBCLIENT_LIBS) \
libneighbor.a
-if HAVE_LIBUPNP
+if ENABLE_UPNP
libneighbor_a_SOURCES += \
$(UPNP_SOURCES) \
src/neighbor/plugins/UpnpNeighborPlugin.cxx src/neighbor/plugins/UpnpNeighborPlugin.hxx
@@ -670,7 +702,7 @@ libdb_plugins_a_SOURCES = \
src/db/plugins/simple/SimpleDatabasePlugin.cxx \
src/db/plugins/simple/SimpleDatabasePlugin.hxx
-if HAVE_LIBMPDCLIENT
+if ENABLE_LIBMPDCLIENT
libdb_plugins_a_SOURCES += \
src/db/plugins/ProxyDatabasePlugin.cxx src/db/plugins/ProxyDatabasePlugin.hxx
endif
@@ -679,7 +711,7 @@ DB_LIBS = \
libdb_plugins.a \
$(LIBMPDCLIENT_LIBS)
-if HAVE_LIBUPNP
+if ENABLE_UPNP
libdb_plugins_a_SOURCES += \
$(UPNP_SOURCES) \
src/db/plugins/upnp/UpnpDatabasePlugin.cxx src/db/plugins/upnp/UpnpDatabasePlugin.hxx \
@@ -701,6 +733,7 @@ if ENABLE_ARCHIVE
noinst_LIBRARIES += libarchive.a
libmpd_a_SOURCES += \
+ src/TagArchive.cxx src/TagArchive.hxx \
src/db/update/Archive.cxx
libarchive_a_SOURCES = \
@@ -722,19 +755,19 @@ ARCHIVE_LIBS = \
$(ISO9660_LIBS) \
$(ZZIP_LIBS)
-if HAVE_BZ2
+if ENABLE_BZ2
libarchive_a_SOURCES += \
src/archive/plugins/Bzip2ArchivePlugin.cxx \
src/archive/plugins/Bzip2ArchivePlugin.hxx
endif
-if HAVE_ZZIP
+if ENABLE_ZZIP
libarchive_a_SOURCES += \
src/archive/plugins/ZzipArchivePlugin.cxx \
src/archive/plugins/ZzipArchivePlugin.hxx
endif
-if HAVE_ISO9660
+if ENABLE_ISO9660
libarchive_a_SOURCES += \
src/archive/plugins/Iso9660ArchivePlugin.cxx \
src/archive/plugins/Iso9660ArchivePlugin.hxx
@@ -749,7 +782,9 @@ endif
libconf_a_SOURCES = \
src/config/ConfigDefaults.hxx \
src/config/ConfigPath.cxx src/config/ConfigPath.hxx \
- src/config/ConfigData.cxx src/config/ConfigData.hxx \
+ src/config/Data.cxx src/config/Data.hxx \
+ src/config/Block.cxx src/config/Block.hxx \
+ src/config/Param.cxx src/config/Param.hxx \
src/config/ConfigParser.cxx src/config/ConfigParser.hxx \
src/config/ConfigGlobal.cxx src/config/ConfigGlobal.hxx \
src/config/ConfigFile.cxx src/config/ConfigFile.hxx \
@@ -778,6 +813,7 @@ libtag_a_SOURCES =\
src/tag/TagPool.cxx src/tag/TagPool.hxx \
src/tag/TagTable.cxx src/tag/TagTable.hxx \
src/tag/Set.cxx src/tag/Set.hxx \
+ src/tag/Format.cxx src/tag/Format.hxx \
src/tag/VorbisComment.cxx src/tag/VorbisComment.hxx \
src/tag/ReplayGain.cxx src/tag/ReplayGain.hxx \
src/tag/MixRamp.cxx src/tag/MixRamp.hxx \
@@ -785,7 +821,7 @@ libtag_a_SOURCES =\
src/tag/ApeReplayGain.cxx src/tag/ApeReplayGain.hxx \
src/tag/ApeTag.cxx src/tag/ApeTag.hxx
-if HAVE_ID3TAG
+if ENABLE_ID3TAG
libtag_a_SOURCES += \
src/tag/TagId3.cxx src/tag/TagId3.hxx \
src/tag/TagRva2.cxx src/tag/TagRva2.hxx \
@@ -795,9 +831,14 @@ endif
# ffmpeg
-if HAVE_FFMPEG
+if ENABLE_FFMPEG
noinst_LIBRARIES += libffmpeg.a
libffmpeg_a_SOURCES = \
+ src/lib/ffmpeg/Init.cxx src/lib/ffmpeg/Init.hxx \
+ src/lib/ffmpeg/Time.hxx \
+ src/lib/ffmpeg/Buffer.hxx \
+ src/lib/ffmpeg/LogError.cxx src/lib/ffmpeg/LogError.hxx \
+ src/lib/ffmpeg/LogCallback.cxx src/lib/ffmpeg/LogCallback.hxx \
src/lib/ffmpeg/Error.cxx src/lib/ffmpeg/Error.hxx \
src/lib/ffmpeg/Domain.cxx src/lib/ffmpeg/Domain.hxx
libffmpeg_a_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -861,25 +902,25 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/DsdLib.hxx
endif
-if HAVE_MAD
+if ENABLE_MAD
libdecoder_a_SOURCES += \
src/decoder/plugins/MadDecoderPlugin.cxx \
src/decoder/plugins/MadDecoderPlugin.hxx
endif
-if HAVE_MPG123
+if ENABLE_MPG123
libdecoder_a_SOURCES += \
src/decoder/plugins/Mpg123DecoderPlugin.cxx \
src/decoder/plugins/Mpg123DecoderPlugin.hxx
endif
-if HAVE_MPCDEC
+if ENABLE_MPCDEC
libdecoder_a_SOURCES += \
src/decoder/plugins/MpcdecDecoderPlugin.cxx \
src/decoder/plugins/MpcdecDecoderPlugin.hxx
endif
-if HAVE_OPUS
+if ENABLE_OPUS
libdecoder_a_SOURCES += \
src/decoder/plugins/OggUtil.cxx \
src/decoder/plugins/OggUtil.hxx \
@@ -895,19 +936,19 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/OpusDecoderPlugin.h
endif
-if HAVE_WAVPACK
+if ENABLE_WAVPACK
libdecoder_a_SOURCES += \
src/decoder/plugins/WavpackDecoderPlugin.cxx \
src/decoder/plugins/WavpackDecoderPlugin.hxx
endif
-if HAVE_ADPLUG
+if ENABLE_ADPLUG
libdecoder_a_SOURCES += \
src/decoder/plugins/AdPlugDecoderPlugin.cxx \
src/decoder/plugins/AdPlugDecoderPlugin.h
endif
-if HAVE_FAAD
+if ENABLE_FAAD
libdecoder_a_SOURCES += \
src/decoder/plugins/FaadDecoderPlugin.cxx src/decoder/plugins/FaadDecoderPlugin.hxx
endif
@@ -925,7 +966,7 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/VorbisDecoderPlugin.cxx src/decoder/plugins/VorbisDecoderPlugin.h
endif
-if HAVE_FLAC
+if ENABLE_FLAC
libdecoder_a_SOURCES += \
src/decoder/plugins/FlacInput.cxx src/decoder/plugins/FlacInput.hxx \
src/decoder/plugins/FlacIOHandle.cxx src/decoder/plugins/FlacIOHandle.hxx \
@@ -937,7 +978,7 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/FlacDecoderPlugin.h
endif
-if HAVE_AUDIOFILE
+if ENABLE_AUDIOFILE
libdecoder_a_SOURCES += \
src/decoder/plugins/AudiofileDecoderPlugin.cxx \
src/decoder/plugins/AudiofileDecoderPlugin.hxx
@@ -949,7 +990,7 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/MikmodDecoderPlugin.hxx
endif
-if HAVE_MODPLUG
+if ENABLE_MODPLUG
libmodplug_decoder_plugin_a_SOURCES = \
src/decoder/plugins/ModplugDecoderPlugin.cxx \
src/decoder/plugins/ModplugDecoderPlugin.hxx
@@ -977,8 +1018,10 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/WildmidiDecoderPlugin.hxx
endif
-if HAVE_FFMPEG
+if ENABLE_FFMPEG
libdecoder_a_SOURCES += \
+ src/decoder/plugins/FfmpegIo.cxx \
+ src/decoder/plugins/FfmpegIo.hxx \
src/decoder/plugins/FfmpegMetaData.cxx \
src/decoder/plugins/FfmpegMetaData.hxx \
src/decoder/plugins/FfmpegDecoderPlugin.cxx \
@@ -991,7 +1034,7 @@ libdecoder_a_SOURCES += \
src/decoder/plugins/SndfileDecoderPlugin.hxx
endif
-if HAVE_GME
+if ENABLE_GME
libdecoder_a_SOURCES += \
src/decoder/plugins/GmeDecoderPlugin.cxx src/decoder/plugins/GmeDecoderPlugin.hxx
endif
@@ -1021,7 +1064,9 @@ ENCODER_LIBS = \
libencoder_plugins_a_SOURCES = \
src/encoder/EncoderAPI.hxx \
+ src/encoder/EncoderInterface.hxx \
src/encoder/EncoderPlugin.hxx \
+ src/encoder/ToOutputStream.cxx src/encoder/ToOutputStream.hxx \
src/encoder/plugins/OggStream.hxx \
src/encoder/plugins/NullEncoderPlugin.cxx \
src/encoder/plugins/NullEncoderPlugin.hxx \
@@ -1040,25 +1085,25 @@ libencoder_plugins_a_SOURCES += \
src/encoder/plugins/WaveEncoderPlugin.hxx
endif
-if ENABLE_VORBIS_ENCODER
+if ENABLE_VORBISENC
libencoder_plugins_a_SOURCES += \
src/encoder/plugins/VorbisEncoderPlugin.cxx \
src/encoder/plugins/VorbisEncoderPlugin.hxx
endif
-if HAVE_OPUS
+if ENABLE_OPUS
libencoder_plugins_a_SOURCES += \
src/encoder/plugins/OpusEncoderPlugin.cxx \
src/encoder/plugins/OpusEncoderPlugin.hxx
endif
-if ENABLE_LAME_ENCODER
+if ENABLE_LAME
libencoder_plugins_a_SOURCES += \
src/encoder/plugins/LameEncoderPlugin.cxx \
src/encoder/plugins/LameEncoderPlugin.hxx
endif
-if ENABLE_TWOLAME_ENCODER
+if ENABLE_TWOLAME
libencoder_plugins_a_SOURCES += \
src/encoder/plugins/TwolameEncoderPlugin.cxx \
src/encoder/plugins/TwolameEncoderPlugin.hxx
@@ -1070,7 +1115,7 @@ libencoder_plugins_a_SOURCES += \
src/encoder/plugins/FlacEncoderPlugin.hxx
endif
-if ENABLE_SHINE_ENCODER
+if ENABLE_SHINE
libencoder_plugins_a_SOURCES += \
src/encoder/plugins/ShineEncoderPlugin.cxx \
src/encoder/plugins/ShineEncoderPlugin.hxx
@@ -1134,7 +1179,7 @@ INPUT_LIBS = \
$(FFMPEG_LIBS2) \
$(MMS_LIBS)
-if HAVE_ALSA
+if ENABLE_ALSA
libinput_a_SOURCES += \
src/input/plugins/AlsaInputPlugin.cxx \
src/input/plugins/AlsaInputPlugin.hxx
@@ -1167,7 +1212,7 @@ libinput_a_SOURCES += \
src/input/plugins/CdioParanoiaInputPlugin.hxx
endif
-if HAVE_FFMPEG
+if ENABLE_FFMPEG
libinput_a_SOURCES += \
src/input/plugins/FfmpegInputPlugin.cxx src/input/plugins/FfmpegInputPlugin.hxx
endif
@@ -1194,12 +1239,12 @@ OUTPUT_LIBS = \
$(ROAR_LIBS) \
$(JACK_LIBS) \
$(OPENAL_LIBS) \
- $(PULSE_LIBS) \
$(SHOUT_LIBS)
OUTPUT_API_SRC = \
src/output/OutputAPI.hxx \
src/output/Internal.hxx \
+ src/output/Wrapper.hxx \
src/output/Registry.cxx src/output/Registry.hxx \
src/output/MultipleOutputs.cxx src/output/MultipleOutputs.hxx \
src/output/OutputThread.cxx \
@@ -1219,7 +1264,7 @@ liboutput_plugins_a_SOURCES = \
MIXER_LIBS = \
libmixer_plugins.a \
- $(PULSE_LIBS)
+ $(PULSE_LIBS2)
MIXER_API_SRC = \
src/mixer/Listener.hxx \
@@ -1231,13 +1276,14 @@ MIXER_API_SRC = \
src/mixer/MixerInternal.hxx
libmixer_plugins_a_SOURCES = \
+ src/mixer/plugins/NullMixerPlugin.cxx \
src/mixer/plugins/SoftwareMixerPlugin.cxx \
src/mixer/plugins/SoftwareMixerPlugin.hxx
libmixer_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(ALSA_CFLAGS) \
$(PULSE_CFLAGS)
-if HAVE_ALSA
+if ENABLE_ALSA
liboutput_plugins_a_SOURCES += \
src/output/plugins/AlsaOutputPlugin.cxx \
src/output/plugins/AlsaOutputPlugin.hxx
@@ -1255,14 +1301,14 @@ liboutput_plugins_a_SOURCES += \
OUTPUT_LIBS += -lOpenSLES
endif
-if HAVE_ROAR
+if ENABLE_ROAR
liboutput_plugins_a_SOURCES += \
src/output/plugins/RoarOutputPlugin.cxx \
src/output/plugins/RoarOutputPlugin.hxx
libmixer_plugins_a_SOURCES += src/mixer/plugins/RoarMixerPlugin.cxx
endif
-if HAVE_AO
+if ENABLE_AO
liboutput_plugins_a_SOURCES += \
src/output/plugins/AoOutputPlugin.cxx \
src/output/plugins/AoOutputPlugin.hxx
@@ -1280,7 +1326,7 @@ liboutput_plugins_a_SOURCES += \
src/output/plugins/PipeOutputPlugin.hxx
endif
-if HAVE_JACK
+if ENABLE_JACK
liboutput_plugins_a_SOURCES += \
src/output/plugins/JackOutputPlugin.cxx \
src/output/plugins/JackOutputPlugin.hxx
@@ -1305,12 +1351,21 @@ liboutput_plugins_a_SOURCES += \
src/output/plugins/OSXOutputPlugin.hxx
endif
-if HAVE_PULSE
+if ENABLE_PULSE
liboutput_plugins_a_SOURCES += \
src/output/plugins/PulseOutputPlugin.cxx \
src/output/plugins/PulseOutputPlugin.hxx
libmixer_plugins_a_SOURCES += \
src/mixer/plugins/PulseMixerPlugin.cxx src/mixer/plugins/PulseMixerPlugin.hxx
+
+noinst_LIBRARIES += libpulse.a
+libpulse_a_SOURCES = \
+ src/lib/pulse/LogError.cxx src/lib/pulse/LogError.hxx \
+ src/lib/pulse/Error.cxx src/lib/pulse/Error.hxx \
+ src/lib/pulse/Domain.cxx src/lib/pulse/Domain.hxx
+libpulse_a_CPPFLAGS = $(AM_CPPFLAGS) $(PULSE_CFLAGS)
+PULSE_LIBS2 = libpulse.a $(PULSE_LIBS)
+OUTPUT_LIBS += $(PULSE_LIBS2)
endif
if HAVE_SHOUT
@@ -1361,15 +1416,12 @@ libplaylist_plugins_a_SOURCES = \
src/playlist/CloseSongEnumerator.hxx \
src/playlist/MemorySongEnumerator.cxx \
src/playlist/MemorySongEnumerator.hxx \
- src/playlist/cue/CueParser.cxx src/playlist/cue/CueParser.hxx \
src/playlist/plugins/ExtM3uPlaylistPlugin.cxx \
src/playlist/plugins/ExtM3uPlaylistPlugin.hxx \
src/playlist/plugins/M3uPlaylistPlugin.cxx \
src/playlist/plugins/M3uPlaylistPlugin.hxx \
- src/playlist/plugins/CuePlaylistPlugin.cxx \
- src/playlist/plugins/CuePlaylistPlugin.hxx \
- src/playlist/plugins/EmbeddedCuePlaylistPlugin.cxx \
- src/playlist/plugins/EmbeddedCuePlaylistPlugin.hxx \
+ src/playlist/plugins/PlsPlaylistPlugin.cxx \
+ src/playlist/plugins/PlsPlaylistPlugin.hxx \
src/playlist/PlaylistRegistry.cxx src/playlist/PlaylistRegistry.hxx
libplaylist_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(EXPAT_CFLAGS) \
@@ -1381,6 +1433,15 @@ PLAYLIST_LIBS = \
$(EXPAT_LIBS) \
$(FLAC_LIBS)
+if ENABLE_CUE
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/cue/CueParser.cxx src/playlist/cue/CueParser.hxx \
+ src/playlist/plugins/CuePlaylistPlugin.cxx \
+ src/playlist/plugins/CuePlaylistPlugin.hxx \
+ src/playlist/plugins/EmbeddedCuePlaylistPlugin.cxx \
+ src/playlist/plugins/EmbeddedCuePlaylistPlugin.hxx
+endif
+
if ENABLE_SOUNDCLOUD
libplaylist_plugins_a_SOURCES += \
src/playlist/plugins/SoundCloudPlaylistPlugin.cxx \
@@ -1388,7 +1449,7 @@ libplaylist_plugins_a_SOURCES += \
PLAYLIST_LIBS += $(YAJL_LIBS)
endif
-if HAVE_EXPAT
+if ENABLE_EXPAT
libplaylist_plugins_a_SOURCES += \
src/lib/expat/ExpatParser.cxx src/lib/expat/ExpatParser.hxx \
src/playlist/plugins/XspfPlaylistPlugin.cxx \
@@ -1399,12 +1460,6 @@ libplaylist_plugins_a_SOURCES += \
src/playlist/plugins/RssPlaylistPlugin.hxx
endif
-if HAVE_GLIB
-libplaylist_plugins_a_SOURCES += \
- src/playlist/plugins/PlsPlaylistPlugin.cxx \
- src/playlist/plugins/PlsPlaylistPlugin.hxx
-endif
-
#
# Filter plugins
#
@@ -1456,7 +1511,8 @@ C_TESTS = \
test/test_mixramp \
test/test_pcm \
test/test_protocol \
- test/test_queue_priority
+ test/test_queue_priority \
+ test/TestIcu
if ENABLE_CURL
C_TESTS += test/test_icy_parser
@@ -1477,6 +1533,7 @@ noinst_PROGRAMS = \
test/read_conf \
test/run_resolver \
test/run_input \
+ test/WriteFile \
test/dump_text_file \
test/dump_playlist \
test/run_decoder \
@@ -1504,11 +1561,11 @@ if ENABLE_ARCHIVE
noinst_PROGRAMS += test/visit_archive
endif
-if HAVE_ID3TAG
+if ENABLE_ID3TAG
noinst_PROGRAMS += test/dump_rva2
endif
-if HAVE_ALSA
+if ENABLE_ALSA
# this debug program is still ALSA specific
noinst_PROGRAMS += test/read_mixer
endif
@@ -1516,6 +1573,7 @@ endif
test_read_conf_LDADD = \
libconf.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1524,7 +1582,7 @@ test_read_conf_SOURCES = \
test/read_conf.cxx
test_run_resolver_LDADD = \
- libsystem.a \
+ libnet.a \
libutil.a \
$(GLIB_LIBS)
test_run_resolver_SOURCES = \
@@ -1556,13 +1614,14 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/TagSave.cxx \
src/SongFilter.cxx
-if HAVE_LIBUPNP
+if ENABLE_UPNP
test_DumpDatabase_SOURCES += src/lib/expat/ExpatParser.cxx
endif
test_run_storage_LDADD = \
$(STORAGE_LIBS) \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libevent.a \
libthread.a \
libsystem.a \
@@ -1581,11 +1640,12 @@ test_run_input_LDADD = \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
libconf.a \
- libutil.a \
libevent.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
+ libutil.a \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.cxx \
test/ScopeIOThread.hxx \
@@ -1609,11 +1669,12 @@ test_run_neighbor_explorer_LDADD = $(AM_LDADD) \
libconf.a \
libevent.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libthread.a \
libutil.a
-if HAVE_LIBUPNP
+if ENABLE_UPNP
test_run_neighbor_explorer_SOURCES += src/lib/expat/ExpatParser.cxx
endif
@@ -1626,11 +1687,12 @@ test_visit_archive_LDADD = \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
libconf.a \
- libutil.a \
libevent.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
+ libutil.a \
$(GLIB_LIBS)
test_visit_archive_SOURCES = test/visit_archive.cxx \
test/ScopeIOThread.hxx \
@@ -1640,7 +1702,7 @@ test_visit_archive_SOURCES = test/visit_archive.cxx \
endif
-if HAVE_ZLIB
+if ENABLE_ZLIB
noinst_PROGRAMS += test/run_gzip test/run_gunzip
@@ -1655,10 +1717,21 @@ test_run_gunzip_LDADD = \
$(GLIB_LIBS) \
libutil.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a
endif
+test_WriteFile_LDADD = \
+ $(FS_LIBS) \
+ $(ICU_LDADD) \
+ libsystem.a \
+ libutil.a \
+ $(GLIB_LIBS)
+test_WriteFile_SOURCES = \
+ src/Log.cxx src/LogBackend.cxx \
+ test/WriteFile.cxx
+
test_dump_text_file_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
@@ -1666,6 +1739,7 @@ test_dump_text_file_LDADD = \
libconf.a \
libevent.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libthread.a \
libutil.a \
@@ -1687,6 +1761,7 @@ test_dump_playlist_LDADD = \
libevent.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
libpcm.a \
@@ -1702,7 +1777,7 @@ test_dump_playlist_SOURCES = test/dump_playlist.cxx \
src/AudioFormat.cxx src/CheckAudioFormat.cxx \
src/DetachedSong.cxx
-if HAVE_FLAC
+if ENABLE_FLAC
test_dump_playlist_SOURCES += \
src/ReplayGainInfo.cxx \
src/decoder/plugins/FlacMetadata.cxx
@@ -1718,6 +1793,7 @@ test_run_decoder_LDADD = \
libevent.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1744,6 +1820,7 @@ test_read_tags_LDADD = \
libevent.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1756,7 +1833,7 @@ test_read_tags_SOURCES = test/read_tags.cxx \
src/AudioFormat.cxx src/CheckAudioFormat.cxx \
$(DECODER_SRC)
-if HAVE_ID3TAG
+if ENABLE_ID3TAG
test_dump_rva2_LDADD = \
$(TAG_LIBS) \
libutil.a \
@@ -1770,6 +1847,7 @@ test_run_filter_LDADD = \
$(FILTER_LIBS) \
libconf.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1798,12 +1876,13 @@ test_run_encoder_LDADD = \
libpcm.a \
libthread.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
endif
-if ENABLE_VORBIS_ENCODER
+if ENABLE_VORBISENC
noinst_PROGRAMS += test/test_vorbis_encoder
test_test_vorbis_encoder_SOURCES = test/test_vorbis_encoder.cxx \
test/stdbin.h \
@@ -1820,6 +1899,7 @@ test_test_vorbis_encoder_LDADD = $(MPD_LIBS) \
$(TAG_LIBS) \
libconf.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1865,7 +1945,11 @@ test_run_convert_SOURCES = test/run_convert.cxx \
src/AudioParser.cxx
test_run_convert_LDADD = \
$(PCM_LIBS) \
+ libconf.a \
+ $(FS_LIBS) \
+ libsystem.a \
libutil.a \
+ $(ICU_LDADD) \
$(GLIB_LIBS)
test_run_output_LDADD = $(MPD_LIBS) \
@@ -1878,6 +1962,8 @@ test_run_output_LDADD = $(MPD_LIBS) \
libconf.a \
libevent.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
+ libnet.a \
libsystem.a \
libthread.a \
libutil.a \
@@ -1907,6 +1993,7 @@ test_read_mixer_LDADD = \
libconf.a \
libevent.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
@@ -1944,6 +2031,9 @@ test_run_inotify_LDADD = \
endif
test_test_util_SOURCES = \
+ test/DivideStringTest.hxx \
+ test/SplitStringTest.hxx \
+ test/UriUtilTest.hxx \
test/TestCircularBuffer.hxx \
test/test_util.cxx
test_test_util_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
@@ -2042,6 +2132,7 @@ test_test_translate_song_LDADD = \
$(STORAGE_LIBS) \
libtag.a \
$(FS_LIBS) \
+ $(ICU_LDADD) \
libsystem.a \
libutil.a \
$(GLIB_LIBS) \
@@ -2070,6 +2161,15 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_TestIcu_SOURCES = \
+ test/TestIcu.cxx
+test_TestIcu_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_TestIcu_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_TestIcu_LDADD = \
+ $(ICU_LDADD) \
+ libutil.a \
+ $(CPPUNIT_LIBS)
+
if ENABLE_DSD
noinst_PROGRAMS += src/pcm/dsd2pcm/dsd2pcm
@@ -2159,4 +2259,4 @@ EXTRA_DIST = $(doc_DATA) autogen.sh \
android/src/Bridge.java \
android/src/Loader.java \
android/src/Main.java \
- src/win32/mpd_win32_rc.rc.in src/win32/mpd.ico
+ win32/res/mpd.rc.in win32/res/mpd.ico