aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 93e4dd499..fdb925a8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -977,6 +977,7 @@ noinst_PROGRAMS = \
test/run_resolver \
test/run_tcp_connect \
test/run_input \
+ test/dump_text_file \
test/dump_playlist \
test/run_decoder \
test/read_tags \
@@ -1021,6 +1022,18 @@ test_run_input_SOURCES = test/run_input.c \
src/tag.c src/tag_pool.c src/tag_save.c \
src/fd_util.c
+test_dump_text_file_LDADD = \
+ $(INPUT_LIBS) \
+ $(ARCHIVE_LIBS) \
+ $(GLIB_LIBS)
+test_dump_text_file_SOURCES = test/dump_text_file.c \
+ test/stdbin.h \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
+ src/tag.c src/tag_pool.c \
+ src/text_input_stream.c src/fifo_buffer.c \
+ src/fd_util.c
+
test_dump_playlist_LDADD = \
$(PLAYLIST_LIBS) \
$(FLAC_LIBS) \
@@ -1117,6 +1130,8 @@ test_read_tags_SOURCES += \
src/despotify_utils.c
test_run_input_SOURCES += \
src/despotify_utils.c
+test_dump_text_file_SOURCES += \
+ src/despotify_utils.c
test_dump_playlist_SOURCES += \
src/despotify_utils.c
test_run_decoder_SOURCES += \