aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am124
1 files changed, 111 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index b3620bdeb..df9be5aaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,7 @@ mpd_headers = \
src/decoder/flac_pcm.h \
src/decoder/_flac_common.h \
src/decoder/_ogg_common.h \
+ src/decoder/pcm_decoder_plugin.h \
src/input_init.h \
src/input_plugin.h \
src/input_registry.h \
@@ -110,6 +111,9 @@ mpd_headers = \
src/input/curl_input_plugin.h \
src/input/rewind_input_plugin.h \
src/input/mms_input_plugin.h \
+ src/input/despotify_input_plugin.h \
+ src/input/cdio_paranoia_input_plugin.h \
+ src/despotify_utils.h \
src/text_file.h \
src/text_input_stream.h \
src/icy_server.h \
@@ -142,6 +146,7 @@ mpd_headers = \
src/output/httpd_client.h \
src/output/httpd_internal.h \
src/output/pulse_output_plugin.h \
+ src/output/roar_output_plugin.h \
src/output/winmm_output_plugin.h \
src/page.h \
src/pcm_buffer.h \
@@ -180,6 +185,7 @@ mpd_headers = \
src/playlist/asx_playlist_plugin.h \
src/playlist/rss_playlist_plugin.h \
src/playlist/lastfm_playlist_plugin.h \
+ src/playlist/despotify_playlist_plugin.h \
src/playlist/cue_playlist_plugin.h \
src/playlist/flac_playlist_plugin.h \
src/poison.h \
@@ -216,6 +222,7 @@ mpd_headers = \
src/strset.h \
src/uri.h \
src/utils.h \
+ src/string_util.h \
src/volume.h \
src/zeroconf.h src/zeroconf-internal.h \
src/locate.h \
@@ -278,16 +285,24 @@ src_mpd_SOURCES = \
src/client_event.c \
src/client_expire.c \
src/client_global.c \
+ src/client_idle.h \
src/client_idle.c \
src/client_list.c \
src/client_new.c \
src/client_process.c \
src/client_read.c \
src/client_write.c \
+ src/client_message.h \
+ src/client_message.c \
+ src/client_subscribe.h \
+ src/client_subscribe.c \
+ src/tcp_socket.c src/tcp_socket.h \
+ src/udp_server.c src/udp_server.h \
src/server_socket.c \
src/listen.c \
src/log.c \
src/ls.c \
+ src/io_thread.c src/io_thread.h \
src/main.c \
src/main_win32.c \
src/event_pipe.c \
@@ -349,11 +364,17 @@ src_mpd_SOURCES = \
src/strset.c \
src/uri.c \
src/utils.c \
+ src/string_util.c \
src/volume.c \
src/locate.c \
src/stored_playlist.c \
src/timer.c
+if ENABLE_DESPOTIFY
+src_mpd_SOURCES += \
+ src/despotify_utils.c
+endif
+
if ENABLE_INOTIFY
src_mpd_SOURCES += \
src/inotify_source.c \
@@ -463,6 +484,7 @@ DECODER_LIBS = \
$(CUE_LIBS)
DECODER_SRC = \
+ src/decoder/pcm_decoder_plugin.c \
src/decoder_buffer.c \
src/decoder_plugin.c \
src/decoder_list.c
@@ -618,11 +640,15 @@ endif
INPUT_CFLAGS = \
$(CURL_CFLAGS) \
+ $(SOUP_CFLAGS) \
+ $(CDIO_PARANOIA_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(MMS_CFLAGS)
INPUT_LIBS = \
$(CURL_LIBS) \
+ $(SOUP_LIBS) \
+ $(CDIO_PARANOIA_LIBS) \
$(FFMPEG_LIBS) \
$(MMS_LIBS)
@@ -638,6 +664,16 @@ INPUT_SRC += src/input/curl_input_plugin.c \
src/icy_metadata.c
endif
+if ENABLE_SOUP
+INPUT_SRC += \
+ src/input/soup_input_plugin.c \
+ src/input/soup_input_plugin.h
+endif
+
+if ENABLE_CDIO_PARANOIA
+INPUT_SRC += src/input/cdio_paranoia_input_plugin.c
+endif
+
if HAVE_FFMPEG
INPUT_SRC += src/input/ffmpeg_input_plugin.c
endif
@@ -646,6 +682,10 @@ if ENABLE_MMS
INPUT_SRC += src/input/mms_input_plugin.c
endif
+if ENABLE_DESPOTIFY
+INPUT_SRC += src/input/despotify_input_plugin.c
+endif
+
OUTPUT_CFLAGS = \
$(AO_CFLAGS) \
@@ -653,6 +693,7 @@ OUTPUT_CFLAGS = \
$(FFADO_CFLAGS) \
$(JACK_CFLAGS) \
$(OPENAL_CFLAGS) \
+ $(OPENSSL_CFLAGS) \
$(PULSE_CFLAGS) \
$(SHOUT_CFLAGS)
@@ -660,6 +701,7 @@ OUTPUT_LIBS = \
$(LIBWRAP_LDFLAGS) \
$(AO_LIBS) \
$(ALSA_LIBS) \
+ $(ROAR_LIBS) \
$(FFADO_LIBS) \
$(JACK_LIBS) \
$(OPENAL_LIBS) \
@@ -674,6 +716,7 @@ OUTPUT_API_SRC = \
src/output_state.c \
src/output_print.c \
src/output_command.c \
+ src/output_finish.c \
src/output_init.c
OUTPUT_SRC = \
@@ -693,6 +736,11 @@ OUTPUT_SRC += src/output/alsa_plugin.c
MIXER_SRC += src/mixer/alsa_mixer_plugin.c
endif
+if HAVE_ROAR
+OUTPUT_SRC += src/output/roar_plugin.c
+MIXER_SRC += src/mixer/roar_mixer_plugin.c
+endif
+
if ENABLE_FFADO_OUTPUT
OUTPUT_SRC += src/output/ffado_output_plugin.c
endif
@@ -730,6 +778,15 @@ if HAVE_OSX
OUTPUT_SRC += src/output/osx_plugin.c
endif
+if ENABLE_RAOP_OUTPUT
+OUTPUT_SRC += \
+ src/ntp_server.c src/ntp_server.h \
+ src/rtsp_client.c src/rtsp_client.h \
+ src/output/raop_output_plugin.c
+MIXER_SRC += src/mixer/raop_mixer_plugin.c
+OUTPUT_LIBS += $(OPENSSL_LIBS)
+endif
+
if HAVE_PULSE
OUTPUT_SRC += src/output/pulse_output_plugin.c
MIXER_SRC += src/mixer/pulse_mixer_plugin.c
@@ -777,6 +834,10 @@ if ENABLE_LASTFM
PLAYLIST_SRC += src/playlist/lastfm_playlist_plugin.c
endif
+if ENABLE_DESPOTIFY
+PLAYLIST_SRC += src/playlist/despotify_playlist_plugin.c
+endif
+
if HAVE_CUE
PLAYLIST_SRC += src/playlist/cue_playlist_plugin.c
endif
@@ -827,14 +888,19 @@ sparse-check:
if ENABLE_TEST
-TESTS =
+C_TESTS = \
+ test/test_queue_priority
+
+TESTS = $(C_TESTS)
noinst_PROGRAMS = \
+ $(C_TESTS) \
test/read_conf \
test/run_input \
test/dump_playlist \
test/run_decoder \
test/read_tags \
+ test/run_ntp_server \
test/run_filter \
test/run_output \
test/run_convert \
@@ -851,7 +917,7 @@ test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
test_read_conf_LDADD = $(MPD_LIBS) \
$(GLIB_LIBS)
test_read_conf_SOURCES = test/read_conf.c \
- src/conf.c src/tokenizer.c src/utils.c
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c
test_run_input_CPPFLAGS = $(AM_CPPFLAGS) \
$(ARCHIVE_CFLAGS) \
@@ -862,7 +928,8 @@ test_run_input_LDADD = $(MPD_LIBS) \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.c \
test/stdbin.h \
- src/conf.c src/tokenizer.c src/utils.c \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
src/tag.c src/tag_pool.c src/tag_save.c \
src/fd_util.c \
$(ARCHIVE_SRC) \
@@ -880,7 +947,8 @@ test_dump_playlist_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.c \
- src/conf.c src/tokenizer.c src/utils.c \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
src/uri.c \
src/song.c src/tag.c src/tag_pool.c src/tag_save.c \
src/text_input_stream.c src/fifo_buffer.c \
@@ -910,7 +978,8 @@ test_run_decoder_LDADD = $(MPD_LIBS) \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.c \
test/stdbin.h \
- src/conf.c src/tokenizer.c src/utils.c src/log.c \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
src/tag.c src/tag_pool.c \
src/replay_gain_info.c \
src/uri.c \
@@ -933,7 +1002,8 @@ test_read_tags_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) $(DECODER_LIBS) \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.c \
- src/conf.c src/tokenizer.c src/utils.c src/log.c \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
src/tag.c src/tag_pool.c \
src/replay_gain_info.c \
src/uri.c \
@@ -945,6 +1015,15 @@ test_read_tags_SOURCES = test/read_tags.c \
$(TAG_SRC) \
$(DECODER_SRC)
+test_run_ntp_server_CPPFLAGS = $(AM_CPPFLAGS)
+test_run_ntp_server_LDADD = $(MPD_LIBS) \
+ $(GLIB_LIBS)
+test_run_ntp_server_SOURCES = test/run_ntp_server.c \
+ test/signals.c test/signals.h \
+ src/io_thread.c src/io_thread.h \
+ src/udp_server.c src/udp_server.h \
+ src/ntp_server.c src/ntp_server.h
+
test_run_filter_CPPFLAGS = $(AM_CPPFLAGS)
test_run_filter_LDADD = $(MPD_LIBS) \
$(SAMPLERATE_LIBS) \
@@ -953,7 +1032,7 @@ test_run_filter_SOURCES = test/run_filter.c \
test/stdbin.h \
src/filter_plugin.c \
src/filter_registry.c \
- src/conf.c src/tokenizer.c src/utils.c \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c \
src/pcm_volume.c src/pcm_convert.c src/pcm_byteswap.c \
src/pcm_format.c src/pcm_channels.c src/pcm_dither.c \
src/pcm_pack.c \
@@ -970,12 +1049,23 @@ if HAVE_LIBSAMPLERATE
test_run_filter_SOURCES += src/pcm_resample_libsamplerate.c
endif
+if ENABLE_DESPOTIFY
+test_read_tags_SOURCES += \
+ src/despotify_utils.c
+test_run_input_SOURCES += \
+ src/despotify_utils.c
+test_dump_playlist_SOURCES += \
+ src/despotify_utils.c
+test_run_decoder_SOURCES += \
+ src/despotify_utils.c
+endif
+
if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.c \
test/stdbin.h \
src/conf.c src/tokenizer.c \
- src/utils.c \
+ src/utils.c src/string_util.c \
src/tag.c src/tag_pool.c \
src/audio_check.c \
src/audio_format.c \
@@ -1036,7 +1126,10 @@ test_run_output_LDADD = $(MPD_LIBS) \
$(GLIB_LIBS)
test_run_output_SOURCES = test/run_output.c \
test/stdbin.h \
- src/conf.c src/tokenizer.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
+ src/io_thread.c src/io_thread.h \
+ src/udp_server.c src/udp_server.h \
+ src/tcp_socket.c src/tcp_socket.h \
src/audio_check.c \
src/audio_format.c \
src/audio_parser.c \
@@ -1045,7 +1138,7 @@ test_run_output_SOURCES = test/run_output.c \
src/fifo_buffer.c \
src/page.c \
src/socket_util.c \
- src/output_init.c src/output_list.c \
+ src/output_init.c src/output_finish.c src/output_list.c \
$(ENCODER_SRC) \
src/mixer_api.c \
src/mixer_control.c \
@@ -1072,7 +1165,7 @@ test_read_mixer_LDADD = $(MPD_LIBS) \
$(OUTPUT_LIBS) \
$(GLIB_LIBS)
test_read_mixer_SOURCES = test/read_mixer.c \
- src/conf.c src/tokenizer.c src/utils.c src/log.c \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
src/mixer_control.c src/mixer_api.c \
src/filter_plugin.c \
src/filter/volume_filter_plugin.c \
@@ -1100,6 +1193,12 @@ test_run_inotify_SOURCES = test/run_inotify.c \
test_run_inotify_LDADD = $(GLIB_LIBS)
endif
+test_test_queue_priority_SOURCES = \
+ src/queue.c \
+ test/test_queue_priority.c
+test_test_queue_priority_LDADD = \
+ $(GLIB_LIBS)
+
endif
@@ -1137,8 +1236,7 @@ endif
doc/api/html/index.html: doc/doxygen.conf
@mkdir -p $(@D)
- [ "$(srcdir)" = "." ] || sed '/INPUT *=/ s/\([^ ]\+\/\)/$(subst /,\/,$(srcdir))\/\1/g' $(srcdir)/doc/doxygen.conf >doc/doxygen.conf
- $(DOXYGEN) doc/doxygen.conf
+ $(DOXYGEN) $<
all-local: $(DOCBOOK_HTML) doc/api/html/index.html