aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b703529a9..020a2aeec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -755,6 +755,8 @@ sparse-check:
if ENABLE_TEST
+TESTS =
+
noinst_PROGRAMS = \
test/read_conf \
test/run_input \
@@ -974,6 +976,18 @@ test_read_mixer_SOURCES = test/read_mixer.c \
src/fd_util.c \
$(MIXER_SRC)
+if ENABLE_BZIP2_TEST
+TESTS += test/test_archive_bzip2.sh
+endif
+
+if ENABLE_ZZIP_TEST
+TESTS += test/test_archive_zzip.sh
+endif
+
+if ENABLE_ISO9660_TEST
+TESTS += test/test_archive_iso9660.sh
+endif
+
endif