aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a84cbbdf..ec38cf4ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1102,7 +1102,8 @@ endif
doc/api/html/index.html: doc/doxygen.conf
@mkdir -p $(@D)
- $(DOXYGEN) $<
+ [ "$(srcdir)" = "." ] || sed '/INPUT *=/ s/\([^ ]\+\/\)/$(subst /,\/,$(srcdir))\/\1/g' $(srcdir)/doc/doxygen.conf >doc/doxygen.conf
+ $(DOXYGEN) doc/doxygen.conf
all-local: $(DOCBOOK_HTML) doc/api/html/index.html