aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-23 20:00:51 +0200
committerMax Kellermann <max@duempel.org>2008-10-23 20:00:51 +0200
commit6b1c54ef9646abddfbd4960c207b32426300a90c (patch)
tree5b3ae6bf5fc377cf9c705c85948ab5b85e31743c /src/Makefile.am
parent098991f8e8a974d2eee39645fa23c43a4c8b06c1 (diff)
downloadmpd-6b1c54ef9646abddfbd4960c207b32426300a90c.tar.gz
mpd-6b1c54ef9646abddfbd4960c207b32426300a90c.tar.xz
mpd-6b1c54ef9646abddfbd4960c207b32426300a90c.zip
pcm_utils: moved code to pcm_resample.c
Separate the resampling code from the rest of pcm_utils.c. Create two sub-libraries: pcm_resample_libsamplerate.c and pcm_resample_fallback.c.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f2bf55eb1..47a121484 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,6 +66,7 @@ mpd_headers = \
path.h \
mapper.h \
pcm_utils.h \
+ pcm_resample.h \
pcm_dither.h \
permission.h \
player_thread.h \
@@ -146,6 +147,7 @@ mpd_SOURCES = \
path.c \
mapper.c \
pcm_utils.c \
+ pcm_resample.c \
pcm_dither.c \
permission.c \
player_thread.c \
@@ -176,6 +178,12 @@ mpd_SOURCES = \
stored_playlist.c \
timer.c
+if HAVE_LIBSAMPLERATE
+mpd_SOURCES += pcm_resample_libsamplerate.c
+else
+mpd_SOURCES += pcm_resample_fallback.c
+endif
+
if HAVE_ID3TAG
mpd_SOURCES += tag_id3.c
endif