aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-12 16:43:18 +0100
committerMax Kellermann <max@duempel.org>2009-02-12 16:43:18 +0100
commit149233946329ae050142e3fe1b9656d7cd9dd1dc (patch)
tree2a363f9e583b2e3355635a0b379eff89d669779c /src/Makefile.am
parente56a90f3b343217671327aba2ecdca8709463331 (diff)
downloadmpd-149233946329ae050142e3fe1b9656d7cd9dd1dc.tar.gz
mpd-149233946329ae050142e3fe1b9656d7cd9dd1dc.tar.xz
mpd-149233946329ae050142e3fe1b9656d7cd9dd1dc.zip
wildmidi: new decoder plugin for MIDI files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 935f8b3d6..37fdb2343 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,6 +13,7 @@ mpd_CPPFLAGS = \
$(MODPLUG_CFLAGS) \
$(SIDPLAY_CFLAGS) \
$(FLUIDSYNTH_CFLAGS) \
+ $(WILDMIDI_CFLAGS) \
$(ID3TAG_CFLAGS) \
$(MAD_CFLAGS) \
$(FFMPEG_CFLAGS) \
@@ -28,6 +29,7 @@ mpd_LDADD = $(MPD_LIBS) \
$(MODPLUG_LIBS) \
$(SIDPLAY_LIBS) \
$(FLUIDSYNTH_LIBS) \
+ $(WILDMIDI_LIBS) \
$(ID3TAG_LIBS) \
$(MAD_LIBS) \
$(MP4FF_LIBS) \
@@ -323,6 +325,10 @@ if ENABLE_FLUIDSYNTH
mpd_SOURCES += decoder/fluidsynth_plugin.c
endif
+if ENABLE_WILDMIDI
+mpd_SOURCES += decoder/wildmidi_plugin.c
+endif
+
if HAVE_FFMPEG
mpd_SOURCES += decoder/ffmpeg_plugin.c
endif