aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-19 18:51:57 +0100
committerMax Kellermann <max@duempel.org>2009-01-19 18:51:57 +0100
commit145ab84d51f262983412143fbb29487a8647adb3 (patch)
tree8fc58be92be2178c86484caca17fae23535e8fad /src/Makefile.am
parentfbed96dcea00db7c2f5044929caebfc06684ea15 (diff)
downloadmpd-145ab84d51f262983412143fbb29487a8647adb3.tar.gz
mpd-145ab84d51f262983412143fbb29487a8647adb3.tar.xz
mpd-145ab84d51f262983412143fbb29487a8647adb3.zip
sticker: new library for storing dynamic information about songs
"Stickers" are pieces of information attached to existing MPD objects (e.g. song files, directories, albums). Clients can create arbitrary name/value pairs. MPD itself does not assume any special meaning in them.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c4cde6952..8b8ed7e75 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -100,6 +100,7 @@ mpd_headers = \
songvec.h \
state_file.h \
stats.h \
+ sticker.h \
tag.h \
tag_internal.h \
tag_pool.h \
@@ -192,6 +193,10 @@ mpd_SOURCES = \
stored_playlist.c \
timer.c
+if ENABLE_SQLITE
+mpd_SOURCES += sticker.c
+endif
+
if HAVE_LIBSAMPLERATE
mpd_SOURCES += pcm_resample_libsamplerate.c
else