aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-27 14:33:41 +0100
committerMax Kellermann <max@duempel.org>2008-12-27 14:33:41 +0100
commit0fe0425dee555027c94a39ca0bca5bac947f4702 (patch)
treeb56c3d787c766cda67b29dcd7664dbd516835373 /src/Makefile.am
parent4c13a276c4340752fe955057cbb8cae82163292d (diff)
downloadmpd-0fe0425dee555027c94a39ca0bca5bac947f4702.tar.gz
mpd-0fe0425dee555027c94a39ca0bca5bac947f4702.tar.xz
mpd-0fe0425dee555027c94a39ca0bca5bac947f4702.zip
disable archive API without plugins
When there are no archive plugins, we do not need the archive API at all. Drop all its overhead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 38ba8b223..b327a8f93 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -158,10 +158,7 @@ mpd_SOURCES = \
volume.c \
locate.c \
stored_playlist.c \
- timer.c \
- archive_api.c \
- archive_list.c \
- input_archive.c
+ timer.c
if HAVE_LIBSAMPLERATE
mpd_SOURCES += pcm_resample_libsamplerate.c
@@ -187,6 +184,14 @@ if HAVE_ISO
mpd_SOURCES += archive/iso_plugin.c
endif
+if ENABLE_ARCHIVE
+mpd_SOURCES += \
+ archive_api.c \
+ archive_list.c \
+ input_archive.c
+endif
+
+
# decoder plugins
if HAVE_MAD