aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-12 15:02:57 +0200
committerMax Kellermann <max@duempel.org>2008-09-12 15:02:57 +0200
commitfcac05a207b6ff969e871984d6a923bc78aad914 (patch)
tree3d01767f3d030fa37ba488677a958642cc8b2d28 /src/Makefile.am
parent7d3ca9c1ffa25c8fd8b53714fa67e140ae655381 (diff)
downloadmpd-fcac05a207b6ff969e871984d6a923bc78aad914.tar.gz
mpd-fcac05a207b6ff969e871984d6a923bc78aad914.tar.xz
mpd-fcac05a207b6ff969e871984d6a923bc78aad914.zip
shout: moved code to audioOutput_shout_ogg.c
Begin dividing audioOutput_shout.c: move everything OGG Vorbis related to audioOutput_shout_ogg.c. The header audioOutput_shout.h has to keep its dependency on vorbis/vorbisenc.h, because it needs the vorbis encoder types. For this patch, we have to export several internal functions with generic names to the ABI; these will be removed later when the encoder plugin patches are merged.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ee20c593f..097722dd8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,6 +3,7 @@ SUBDIRS = $(MP4FF_SUBDIR)
mpd_audioOutputs = \
audioOutputs/audioOutput_shout.c \
+ audioOutputs/audioOutput_shout_ogg.c \
audioOutputs/audioOutput_null.c \
audioOutputs/audioOutput_fifo.c \
audioOutputs/audioOutput_alsa.c \