aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-08 11:47:57 +0200
committerMax Kellermann <max@duempel.org>2008-09-08 11:47:57 +0200
commitf0e64ceb48c485baf32528bba44875885d384354 (patch)
treec9869f5a5dd25a7eb88791ca6aa95f7c0e77168c /src/Makefile.am
parent2b8040b42524dad68ea85c45a4be25909a03eb5c (diff)
downloadmpd-f0e64ceb48c485baf32528bba44875885d384354.tar.gz
mpd-f0e64ceb48c485baf32528bba44875885d384354.tar.xz
mpd-f0e64ceb48c485baf32528bba44875885d384354.zip
use strset.h instead of tagTracker.h
With a large music database, the linear string collection in tagTracker.c becomes very slow. We implemented that in a quick'n'dirty fashion when we removed tree.c, and now we rewrite it using the fast hashed string set.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5a5439bfc..076802015 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,7 +90,6 @@ mpd_headers = \
tag_id3.h \
tag_print.h \
tag_save.h \
- tagTracker.h \
utf8.h \
strset.h \
utils.h \
@@ -158,7 +157,6 @@ mpd_SOURCES = \
tag_id3.c \
tag_print.c \
tag_save.c \
- tagTracker.c \
strset.c \
utils.c \
volume.c \