aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-22 17:11:14 +0100
committerMax Kellermann <max@duempel.org>2009-02-22 17:11:14 +0100
commita9dde676be62195aace54a1e3defefdc78a317f1 (patch)
treefe87ba691238df26f380fc36652f65e32dc4debe /src/Makefile.am
parente79a82ba3a5988442426104d97ae0c549d0df62a (diff)
downloadmpd-a9dde676be62195aace54a1e3defefdc78a317f1.tar.gz
mpd-a9dde676be62195aace54a1e3defefdc78a317f1.tar.xz
mpd-a9dde676be62195aace54a1e3defefdc78a317f1.zip
added the encoder API
The new generic encoder API will replace shout's custom encoder API.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 237d313f0..2ec4c9ccc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -73,6 +73,9 @@ mpd_headers = \
directory_save.h \
directory_print.h \
database.h \
+ encoder_plugin.h \
+ encoder_list.h \
+ encoder_api.h \
update.h \
dirvec.h \
gcc.h \
@@ -341,6 +344,12 @@ if HAVE_FFMPEG
mpd_SOURCES += decoder/ffmpeg_plugin.c
endif
+# encoder plugins
+
+if ENABLE_ENCODER
+mpd_SOURCES += encoder_list.c
+endif
+
if HAVE_ZEROCONF
mpd_SOURCES += zeroconf.c