aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-15 19:36:30 +0200
committerMax Kellermann <max@duempel.org>2008-10-15 19:36:30 +0200
commit8746a58ab93f0662bf1e8b91a36c261822ffeed5 (patch)
treeecacc9d8c682cb2621cbd8d3298ef7e3ee056542 /src/Makefile.am
parente89599eaad23990973efd43f01cb802917a31cff (diff)
downloadmpd-8746a58ab93f0662bf1e8b91a36c261822ffeed5.tar.gz
mpd-8746a58ab93f0662bf1e8b91a36c261822ffeed5.tar.xz
mpd-8746a58ab93f0662bf1e8b91a36c261822ffeed5.zip
path, tag_id3: use g_convert() instead of charConv.c
GLib provides an easier API for character set conversion than iconv(). Use g_convert() / g_convert_with_fallback() for all character conversions. We should optimize the path.h API later to return a newly allocated buffer, so we can just pass GLib's return value.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 41bc69f05..3652caaa9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,7 +45,6 @@ mpd_headers = \
output_control.h \
audioOutputs/audioOutput_shout.h \
buffer2array.h \
- charConv.h \
command.h \
idle.h \
condition.h \
@@ -131,7 +130,6 @@ mpd_SOURCES = \
output_control.c \
output_init.c \
buffer2array.c \
- charConv.c \
command.c \
idle.c \
condition.c \