aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-07 13:36:05 +0200
committerMax Kellermann <max@duempel.org>2008-09-07 13:36:05 +0200
commit59efed3e8e3da3be85fada02a533cb79fba21569 (patch)
tree6e9204a7e9135bf4bfbe2be53a99ffeec3629b23 /src/Makefile.am
parent75aa8dad4ccf1bb942c327d78b0ddad821c4abaa (diff)
downloadmpd-59efed3e8e3da3be85fada02a533cb79fba21569.tar.gz
mpd-59efed3e8e3da3be85fada02a533cb79fba21569.tar.xz
mpd-59efed3e8e3da3be85fada02a533cb79fba21569.zip
tag: added buffered versions of the tag_print.c code
Currently, when the tag cache is being serialized to hard disk, the stdio buffer is flushed before every song, because tag_print.c performs unbuffered writes on the raw file descriptor. Unfortunately, the fdprintf() API allows buffered I/O only for a client connection by looking up the client pointer owning the file descriptor - for stdio, this is not possible. To re-enable proper stdio buffering, we have to duplicate the tag_print.c code without fprintf() instead of our custom fdprintf() hack. Add this duplicated code to tag_save.c.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba7b7c3a3..1a631d1c6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -88,6 +88,7 @@ mpd_headers = \
tag_pool.h \
tag_id3.h \
tag_print.h \
+ tag_save.h \
tagTracker.h \
utf8.h \
utils.h \
@@ -154,6 +155,7 @@ mpd_SOURCES = \
tag_pool.c \
tag_id3.c \
tag_print.c \
+ tag_save.c \
tagTracker.c \
utils.c \
volume.c \