aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-12 08:43:26 +0100
committerMax Kellermann <max@duempel.org>2009-02-12 08:43:26 +0100
commite56a90f3b343217671327aba2ecdca8709463331 (patch)
tree0ab34e9937cd5080db0a4dd0a571ec1874f41fb0 /src/Makefile.am
parentde2e13cafe7157fa08893824c4fdbdae343c6d2e (diff)
downloadmpd-e56a90f3b343217671327aba2ecdca8709463331.tar.gz
mpd-e56a90f3b343217671327aba2ecdca8709463331.tar.xz
mpd-e56a90f3b343217671327aba2ecdca8709463331.zip
fluidsynth: new decoder plugin for MIDI files
There are a few problems left in this plugin: - fluidsynth decodes in real time, while MPD prefers to buffer as quickly as possible; as a workaround, this plugin uses a timer object to synchronize with real-time playback - I don't know yet how fluidsynth tells me when the song has ended - the "soundfont" configuration setting is not yet documented, and it will likely change soon (in favor of a per-decoder configuration block)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8170badbe..935f8b3d6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,6 +12,7 @@ mpd_CPPFLAGS = \
$(AUDIOFILE_CFLAGS) $(LIBMIKMOD_CFLAGS) \
$(MODPLUG_CFLAGS) \
$(SIDPLAY_CFLAGS) \
+ $(FLUIDSYNTH_CFLAGS) \
$(ID3TAG_CFLAGS) \
$(MAD_CFLAGS) \
$(FFMPEG_CFLAGS) \
@@ -26,6 +27,7 @@ mpd_LDADD = $(MPD_LIBS) \
$(AUDIOFILE_LIBS) $(LIBMIKMOD_LIBS) \
$(MODPLUG_LIBS) \
$(SIDPLAY_LIBS) \
+ $(FLUIDSYNTH_LIBS) \
$(ID3TAG_LIBS) \
$(MAD_LIBS) \
$(MP4FF_LIBS) \
@@ -317,6 +319,10 @@ if ENABLE_SIDPLAY
mpd_SOURCES += decoder/sidplay_plugin.cxx
endif
+if ENABLE_FLUIDSYNTH
+mpd_SOURCES += decoder/fluidsynth_plugin.c
+endif
+
if HAVE_FFMPEG
mpd_SOURCES += decoder/ffmpeg_plugin.c
endif