aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-30 16:43:58 +0100
committerMax Kellermann <max@duempel.org>2008-12-30 16:43:58 +0100
commit49fa9708d51b907f0a372a1fc68a1e27c9edae5e (patch)
treed943b16f8943190cc4225040d67761a61d0394df /src/Makefile.am
parentbbed35822e52a204bf3d82e5df4bb8d00b67af39 (diff)
downloadmpd-49fa9708d51b907f0a372a1fc68a1e27c9edae5e.tar.gz
mpd-49fa9708d51b907f0a372a1fc68a1e27c9edae5e.tar.xz
mpd-49fa9708d51b907f0a372a1fc68a1e27c9edae5e.zip
zeroconf: moved code to zeroconf-avahi.c and zeroconf-bonjour.c
Moved implementation specific code to their own sources, internal declarations in zeroconf-internal.h.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f9fe0b0cf..6a8894cbe 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -79,7 +79,7 @@ mpd_headers = \
utils.h \
volume.h \
ioops.h \
- zeroconf.h \
+ zeroconf.h zeroconf-internal.h \
locate.h \
stored_playlist.h \
timer.h \
@@ -256,6 +256,14 @@ endif
if HAVE_ZEROCONF
mpd_SOURCES += zeroconf.c
+
+if HAVE_AVAHI
+mpd_SOURCES += zeroconf-avahi.c
+endif
+
+if HAVE_BONJOUR
+mpd_SOURCES += zeroconf-bonjour.c
+endif
endif