aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
committerMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
commitf41b9942af7278ab67dc799ad6c17ad74dc0aa1b (patch)
tree69c7c715ff3abd78bb26a7a4d80dd1da5fd5c08b /src/Makefile.am
parent4d01c183b4c1e4c51dff3d9aeec1c01ce13a4323 (diff)
downloadmpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.gz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.xz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.zip
lyrics: converted in-process plugins to external programs
In-process plugins are very problematic. It is much easier and flexible to move the lyrics plugins to external programs, with a trivial protocol. This is work in progress, among the things missing: - protocol specification, including exit codes - plugin installation - plugin search directory - run-time configuration (currently hard coded) - automatic polling (using glib's main loop?) - better and more robust error handling
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 21bef4d20..31cabfda0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,21 +3,18 @@
AM_CPPFLAGS = \
$(GLIB_CFLAGS)\
$(GTHREAD_CFLAGS)\
- $(GMODULE_CFLAGS)\
-DLOCALE_DIR=\""$(datadir)/locale"\"\
-DSYSCONFDIR=\""$(sysconfdir)"\"
ncmpc_LDADD = \
$(GLIB_LIBS)\
- $(GTHREAD_LIBS)\
- $(GMODULE_LIBS)
+ $(GTHREAD_LIBS)
ncmpc_headers = \
libmpdclient.h\
song.h \
mpdclient.h\
playlist.h \
- easy_download.h\
options.h\
conf.h\
command.h\
@@ -31,7 +28,7 @@ ncmpc_headers = \
utils.h\
ncmpc.h\
screen_browse.h\
- src_lyrics.h \
+ lyrics.h \
str_pool.h \
gcc.h
@@ -50,7 +47,6 @@ ncmpc_SOURCES = \
options.c\
conf.c\
command.c\
- easy_download.c\
screen.c\
screen_utils.c\
screen_play.c\
@@ -67,19 +63,9 @@ ncmpc_SOURCES = \
wreadln.c\
strfsong.c\
utils.c\
- src_lyrics.c \
+ lyrics.c \
str_pool.c
-if LEOSLYRICS_FIXED
-ncmpc_SOURCES+=lyrics_leoslyrics.c
-AM_CPPFLAGS+=${libcurl_CFLAGS}
-ncmpc_LDADD+=${libcurl_LIBS}
-endif
-
-if HD_FIXED
-ncmpc_SOURCES+=lyrics_hd.c
-endif
-
ncmpc_SOURCES+=${ncmpc_headers}