aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Jansen <mithi@mithi.net>2008-11-07 08:16:41 +0100
committerMax Kellermann <max@duempel.org>2008-11-07 08:16:41 +0100
commitd88a1718bbca660e13ad60f8f1aec6084fcf7788 (patch)
tree808e721f1fffeafa4a9fa6e169e5467ae3dd28f3 /src/Makefile.am
parent8221502e87f6c1a652b7c3148467248f538970bd (diff)
downloadmpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.tar.gz
mpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.tar.xz
mpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.zip
native LIRC support for ncmpc
The attachment includes the patch and a sample .lircrc config for testing purposes (i. e. only a few commands are mapped to IR events). The config is rather simple to write: For each button add a block like this to ~/.lircrc: begin button = <button name from /etc/lircd.conf> prog = ncmpc config = <command name from src/command.c> end The patch is not finished, there are several problems that still need to be solved: 1. the configure.ac modifications are just for testing purposes and should be made optional with a parameter like --enable-lirc for ./configure. Unfortunately I'm not an expert on autoconfig tools. 2. LIRC example code [1] suggests looping over lirc_code2char, probably to have multiple actions that can be triggered from one button. Perhaps lirc_event(...) should be moved to lirc.c and be heavily modified, no longer being a mere copy of keyboard_event(...).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 68af70ddd..57d1eb605 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,6 +37,7 @@ ncmpc_headers = \
screen_browser.h \
lyrics.h \
str_pool.h \
+ lirc.h \
gcc.h
# $Id$
@@ -89,6 +90,10 @@ if ENABLE_LYRICS_SCREEN
ncmpc_SOURCES += screen_lyrics.c lyrics.c
endif
+if ENABLE_LIRC
+ncmpc_SOURCES += lirc.c
+endif
+
ncmpc_SOURCES+=${ncmpc_headers}