aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-25 20:00:03 +0200
committerMax Kellermann <max@duempel.org>2008-09-25 20:00:03 +0200
commitcee4c0450e477e6b683fb3db883227c2a7fa423f (patch)
tree6d38e37ce065a8db8e7444fae5ab317cf97108f7 /src/Makefile.am
parentf87fea3cd0792de52c0620c329b67db096a7a687 (diff)
downloadmpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.tar.gz
mpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.tar.xz
mpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.zip
screen: don't compile disabled sources
Instead of evaluating macros from config.h in the disabled source, don't start the compiler on it at all.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9a2d5c022..f91c2cff5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,20 +58,31 @@ ncmpc_SOURCES = \
screen_play.c\
screen_browser.c\
screen_file.c\
- screen_artist.c\
- screen_search.c\
screen_help.c\
- screen_lyrics.c\
- screen_keydef.c\
list_window.c\
colors.c\
support.c\
wreadln.c\
strfsong.c\
utils.c\
- lyrics.c \
str_pool.c
+if ENABLE_ARTIST_SCREEN
+ncmpc_SOURCES += screen_artist.c
+endif
+
+if ENABLE_SEARCH_SCREEN
+ncmpc_SOURCES += screen_search.c
+endif
+
+if ENABLE_KEYDEF_SCREEN
+ncmpc_SOURCES += screen_keydef.c
+endif
+
+if ENABLE_LYRICS_SCREEN
+ncmpc_SOURCES += screen_lyrics.c lyrics.c
+endif
+
ncmpc_SOURCES+=${ncmpc_headers}