aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-08-29 09:38:31 +0200
committerEric Wong <normalperson@yhbt.net>2008-09-02 00:19:36 -0700
commit62f527a609d14890886580fe453a9219ae0a2bf7 (patch)
tree421c81b8b57eab5724cf805c203b5607a3d12738 /src/Makefile.am
parent6aa1a7a2565bd1789fd34c7c71d5dbb34eaa1fee (diff)
downloadmpd-62f527a609d14890886580fe453a9219ae0a2bf7.tar.gz
mpd-62f527a609d14890886580fe453a9219ae0a2bf7.tar.xz
mpd-62f527a609d14890886580fe453a9219ae0a2bf7.zip
removed tree.c
This patch makes MPD consume much more memory because string pooling is disabled, but it prepares the next bunch of patches. Replace the code in tagTracker.c with naive algorithms without the tree code. For now, this should do; later we should find better algorithms, especially for getNumberOfTagItems(), which has become wasteful with temporary memory.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d7deb1190..d7049cd99 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,7 +83,6 @@ mpd_headers = \
tag.h \
tag_id3.h \
tagTracker.h \
- tree.h \
utf8.h \
utils.h \
volume.h \
@@ -141,7 +140,6 @@ mpd_SOURCES = \
tag.c \
tag_id3.c \
tagTracker.c \
- tree.c \
utils.c \
volume.c \
utf8.c \