aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-08-16 09:28:15 -0700
committerEric Wong <normalperson@yhbt.net>2008-08-16 09:39:32 -0700
commit44d9f62f34e0561d83ea32941f0ea1b529b1490d (patch)
tree5345eba046b6e3bcf8c063e7bae8b501b7a99f4a /src/Makefile.am
parentf9f70860622613686e6ac0bf7ebd448f437d92a7 (diff)
downloadmpd-44d9f62f34e0561d83ea32941f0ea1b529b1490d.tar.gz
mpd-44d9f62f34e0561d83ea32941f0ea1b529b1490d.tar.xz
mpd-44d9f62f34e0561d83ea32941f0ea1b529b1490d.zip
core rewrite (decode,player,outputBuffer,playlist)
This is a huge refactoring of the core mpd process. The queueing/buffering mechanism is heavily reworked. The player.c code has been merged into outputBuffer (the actual ring buffering logic is handled by ringbuf.c); and decode.c actually handles decoding stuff. The end result is several hundreds of lines shorter, even though we still have a lot of DEBUG statements left in there for tracing and a lot of assertions, too.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d79bda29f..93943db23 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,8 +29,8 @@ mpd_inputPlugins = \
mpd_headers = \
- notify.h \
ack.h \
+ action_status.h \
audio.h \
audioOutput.h \
buffer2array.h \
@@ -61,10 +61,14 @@ mpd_headers = \
compress.h \
os_compat.h \
outputBuffer.h \
+ outputBuffer_accessors.h \
+ outputBuffer_audio.h \
+ outputBuffer_ob_send.h \
+ outputBuffer_xfade.h \
path.h \
pcm_utils.h \
permission.h \
- player.h \
+ player_error.h \
playerData.h \
playlist.h \
replayGain.h \
@@ -92,7 +96,6 @@ mpd_SOURCES = \
$(mpd_headers) \
$(mpd_audioOutputs) \
$(mpd_inputPlugins) \
- notify.c \
audio.c \
audioOutput.c \
buffer2array.c \
@@ -122,7 +125,7 @@ mpd_SOURCES = \
path.c \
pcm_utils.c \
permission.c \
- player.c \
+ player_error.c \
playerData.c \
playlist.c \
replayGain.c \