aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-09-09 01:40:59 -0700
committerEric Wong <normalperson@yhbt.net>2008-09-09 01:40:59 -0700
commit1c3e345d833edb4ce0d7a398212e24c32becba04 (patch)
tree190651f2ede4608648170855fbda468de21d75c8 /src/Makefile.am
parentbb59a92bdb4f5b832a75ef9ff2c42aae58bdd7e9 (diff)
parent0e645468c6249800f573efaa4bca94753245d7e0 (diff)
downloadmpd-1c3e345d833edb4ce0d7a398212e24c32becba04.tar.gz
mpd-1c3e345d833edb4ce0d7a398212e24c32becba04.tar.xz
mpd-1c3e345d833edb4ce0d7a398212e24c32becba04.zip
Merge branch 'mk/client'
* mk/client: (24 commits) client: reorder function declarations client: check "expired" after command execution client: added global "expired" flag client: removed superfluous assertion client: more assertions client: moved code to sockaddr_to_tmp_string() client: replace "expired" flag with fd==-1 client: moved "expired" accesses into inline function client: no while loop in client_manager_io() client: select() errors are fatal client: use client_defer_output() in client_write() client: moved code to client_write() client: client_defer_output() can create the first defer buffer client: return early on error in client_defer_output() client: moved code to client_defer_output() client: don't free client resources except in client_close() client: allocate clients dynamically client: added function client_by_fd() client: return early in client_new() client: renamed all public functions ...
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0592d8e72..15efaf78e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,8 +49,9 @@ mpd_headers = \
inputStream_file.h \
inputStream_http.h \
inputStream_http_auth.h \
- interface.h \
+ client.h \
list.h \
+ dlist.h \
listen.h \
log.h \
ls.h \
@@ -112,7 +113,7 @@ mpd_SOURCES = \
inputStream.c \
inputStream_file.c \
inputStream_http.c \
- interface.c \
+ client.c \
ioops.c \
list.c \
listen.c \