aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-08 11:47:57 +0200
committerEric Wong <normalperson@yhbt.net>2008-09-09 00:40:26 -0700
commit09dccb79f611110a5a653030c7c21958eda95a03 (patch)
treec1132f3228146c9543806c36451056a61a1f7f8e /src/Makefile.am
parent65c88720fbc08bb9ca2cb37ffa75fd842ff3f1d1 (diff)
downloadmpd-09dccb79f611110a5a653030c7c21958eda95a03.tar.gz
mpd-09dccb79f611110a5a653030c7c21958eda95a03.tar.xz
mpd-09dccb79f611110a5a653030c7c21958eda95a03.zip
use strset.h instead of tagTracker.h
With a large music database, the linear string collection in tagTracker.c becomes very slow. We implemented that in a quick'n'dirty fashion when we removed tree.c, and now we rewrite it using the fast hashed string set.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fcb313418..0592d8e72 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,7 +83,6 @@ mpd_headers = \
tag.h \
tag_pool.h \
tag_id3.h \
- tagTracker.h \
utf8.h \
strset.h \
utils.h \
@@ -142,7 +141,6 @@ mpd_SOURCES = \
tag.c \
tag_pool.c \
tag_id3.c \
- tagTracker.c \
strset.c \
utils.c \
volume.c \