aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-25 21:24:57 +0200
committerMax Kellermann <max@duempel.org>2008-09-25 21:24:57 +0200
commitf825f27654988e107272c3a408ac5934f7731e34 (patch)
tree23abc2c14230a7038a603c7f55cea35f79cada18 /src/Makefile.am
parentfb70ff1a3441d1076ba9eafe61d94b81190dda44 (diff)
downloadmpd-f825f27654988e107272c3a408ac5934f7731e34.tar.gz
mpd-f825f27654988e107272c3a408ac5934f7731e34.tar.xz
mpd-f825f27654988e107272c3a408ac5934f7731e34.zip
Makefile: added "sparse-check" target
Diffstat (limited to '')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 106cd3e2e..800799613 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -88,3 +88,18 @@ endif
ncmpc_SOURCES+=${ncmpc_headers}
+#
+# sparse
+#
+
+SPARSE = sparse
+SPARSE_FLAGS = -Wdecl -Wdefault-bitfield-sign -Wdo-while -Wenum-mismatch \
+ -Wnon-pointer-null -Wptr-subtraction-blows -Wreturn-void \
+ -Wshadow -Wtypesign \
+ -D__transparent_union__=unused
+
+sparse-check:
+ for i in $(ncmpc_SOURCES); \
+ do \
+ $(SPARSE) -I. -I.. -I/usr/lib/gcc/$(shell gcc -dumpmachine)/4.3/include -I/usr/lib/gcc/$(shell gcc -dumpmachine)/4.3/include-fixed $(AM_CPPFLAGS) $(SPARSE_FLAGS) $(srcdir)/$$i || exit; \
+ done