aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-15 13:27:33 +0200
committerMax Kellermann <max@duempel.org>2008-09-15 13:27:33 +0200
commit3ef31f6e0c13aa7b2ebd1fcacd7e1aa3ac560ba5 (patch)
tree030fa5ddb7b619d841db4daa2319c15712420778 /src/Makefile.am
parent5f844850f75932d43c3a8bf03d0821bd438295bc (diff)
downloadmpd-3ef31f6e0c13aa7b2ebd1fcacd7e1aa3ac560ba5.tar.gz
mpd-3ef31f6e0c13aa7b2ebd1fcacd7e1aa3ac560ba5.tar.xz
mpd-3ef31f6e0c13aa7b2ebd1fcacd7e1aa3ac560ba5.zip
manage tag string allocations in a pool
There are many duplicated strings in the tag database, e.g. many songs having the same artist. Don't allocate such strings twice, manage all strings in a pool.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 176edf251..53342ff54 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,6 +30,7 @@ ncmpc_headers = \
ncmpc.h\
screen_browse.h\
src_lyrics.h \
+ str_pool.h \
gcc.h
# $Id$
@@ -62,7 +63,8 @@ ncmpc_SOURCES = \
wreadln.c\
strfsong.c\
utils.c\
- src_lyrics.c
+ src_lyrics.c \
+ str_pool.c
if LEOSLYRICS_FIXED
ncmpc_SOURCES+=lyrics_leoslyrics.c