aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-12 18:46:48 +0100
committerMax Kellermann <max@duempel.org>2008-12-12 18:46:48 +0100
commit041b59e39d320fff89e02a853cd162ba88b909cf (patch)
treedf07140954835c5e6c89ba48f234c9b22c1746f6 /src/Makefile.am
parent2ef2f5cd06ceaf086fe5410badd811b8feb980c0 (diff)
downloadmpd-041b59e39d320fff89e02a853cd162ba88b909cf.tar.gz
mpd-041b59e39d320fff89e02a853cd162ba88b909cf.tar.xz
mpd-041b59e39d320fff89e02a853cd162ba88b909cf.zip
plugin: new plugin library
The plugin library is based on code from lyrics.c.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c91df2676..00783807f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,6 +39,7 @@ ncmpc_headers = \
defaults.h \
i18n.h \
screen_browser.h \
+ plugin.h \
lyrics.h \
str_pool.h \
lirc.h
@@ -100,6 +101,10 @@ if ENABLE_KEYDEF_SCREEN
ncmpc_SOURCES += screen_keydef.c
endif
+if ENABLE_PLUGIN_LIBRARY
+ncmpc_SOURCES += plugin.c
+endif
+
if ENABLE_LYRICS_SCREEN
ncmpc_SOURCES += screen_lyrics.c lyrics.c
endif