aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-16 19:11:39 +0200
committerMax Kellermann <max@duempel.org>2008-09-16 19:11:39 +0200
commiteee102e5ddd2c400d707bffe21d9c6ec74507371 (patch)
tree82a1f8db8290c2648849a60dd145098a3fd515a4 /src/Makefile.am
parent9e94b7cb6eebcf40d2508cc365dbc7c221071454 (diff)
downloadmpd-eee102e5ddd2c400d707bffe21d9c6ec74507371.tar.gz
mpd-eee102e5ddd2c400d707bffe21d9c6ec74507371.tar.xz
mpd-eee102e5ddd2c400d707bffe21d9c6ec74507371.zip
mpdclient: moved code to playlist.c
Move everything which manipulates the mpdclient_playlist struct to playlist.c. Many of the functions get a mpdclient pointer instead of a playlist; this will be changed later. The functions mpdclient_playlist_update() and mpdclient_playlist_update_changes() stay in mpdclient.c for now, since they are tightly connected to the client code.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 857c97cc2..21bef4d20 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,6 +16,7 @@ ncmpc_headers = \
libmpdclient.h\
song.h \
mpdclient.h\
+ playlist.h \
easy_download.h\
options.h\
conf.h\
@@ -45,6 +46,7 @@ ncmpc_SOURCES = \
song.c \
main.c\
mpdclient.c\
+ playlist.c \
options.c\
conf.c\
command.c\