aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-08-29 09:38:37 +0200
committerEric Wong <normalperson@yhbt.net>2008-09-02 00:20:08 -0700
commit318a284906f0e594f7c70c6fe72f234923fb6153 (patch)
tree6a29e53581c81fec0f10175c759fec276fb5be86 /src/Makefile.am
parentb24dbaef8dc73ccff85ae3948ff508c1cab4ede9 (diff)
downloadmpd-318a284906f0e594f7c70c6fe72f234923fb6153.tar.gz
mpd-318a284906f0e594f7c70c6fe72f234923fb6153.tar.xz
mpd-318a284906f0e594f7c70c6fe72f234923fb6153.zip
tag: added a pool for tag items
The new source tag_pool.c manages a pool of reference counted tag_item objects. This is used to merge tag items of the same type and value, saving lots of memory. Formerly, only the value itself was pooled, wasting memory for all the pointers and tag_item structs. The following results were measured with massif. Started MPD on amd64, typed "mpc", no song being played. My music database contains 35k tagged songs. The results are what massif reports as "peak". 0.13.2: total 14,131,392; useful 11,408,972; extra 2,722,420 eric: total 18,370,696; useful 15,648,182; extra 2,722,514 mk f34f694: total 15,833,952; useful 13,111,470; extra 2,722,482 mk now: total 12,837,632; useful 10,626,383; extra 2,211,249 This patch set saves 20% memory, and does a good job in reducing heap fragmentation.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d7049cd99..d8640d304 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -81,6 +81,7 @@ mpd_headers = \
state_file.h \
stats.h \
tag.h \
+ tag_pool.h \
tag_id3.h \
tagTracker.h \
utf8.h \
@@ -138,6 +139,7 @@ mpd_SOURCES = \
state_file.c \
stats.c \
tag.c \
+ tag_pool.c \
tag_id3.c \
tagTracker.c \
utils.c \