aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-09-20 16:20:48 -0700
committerEric Wong <normalperson@yhbt.net>2008-09-20 16:58:31 -0700
commit1952b762b0b7024c6a993e62ad957718ac669ac4 (patch)
treeb85434889e082ff3425d2c5209fc8dc41e5fedf4 /src/Makefile.am
parent8f475cc0ff4640f60c139e037b38d5c0225e1478 (diff)
downloadmpd-1952b762b0b7024c6a993e62ad957718ac669ac4.tar.gz
mpd-1952b762b0b7024c6a993e62ad957718ac669ac4.tar.xz
mpd-1952b762b0b7024c6a993e62ad957718ac669ac4.zip
Replace SongList with struct songvec
Our linked-list implementation is wasteful and the SongList isn't modified enough to benefit from being a linked list. So use a more compact array of song pointers which saves ~200K on a library with ~9K songs (on x86-32).
Diffstat (limited to '')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15efaf78e..88774fff1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -79,6 +79,7 @@ mpd_headers = \
sig_handlers.h \
sllist.h \
song.h \
+ songvec.h \
state_file.h \
stats.h \
tag.h \
@@ -137,6 +138,7 @@ mpd_SOURCES = \
signal_check.c \
sllist.c \
song.c \
+ songvec.c \
state_file.c \
stats.c \
tag.c \