aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-08 06:55:10 +0200
committerEric Wong <normalperson@yhbt.net>2008-10-11 19:21:47 -0700
commit0b4c78339608179841838798517485208cee08a2 (patch)
tree721c0adc45b7a53af2fe5ec60dfb4b6dcc76b682 /src/Makefile.am
parentb0dd57ac8f35755b5d367365d1a80d3a5b9527e8 (diff)
downloadmpd-0b4c78339608179841838798517485208cee08a2.tar.gz
mpd-0b4c78339608179841838798517485208cee08a2.tar.xz
mpd-0b4c78339608179841838798517485208cee08a2.zip
dirvec: moved code to dirvec.c
Having all functions as static (non-inline) functions generates GCC warnings, and duplicates binary code across several object files. Most of dirvec's methods are too complex for becoming inline functions. Move them all to dirvec.c and publish the prototypes in dirvec.h.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bfefd5eec..89577360c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -113,6 +113,7 @@ mpd_SOURCES = \
dbUtils.c \
decode.c \
directory.c \
+ dirvec.c \
inputPlugin.c \
inputStream.c \
inputStream_file.c \