aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/hd/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
committerMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
commitf41b9942af7278ab67dc799ad6c17ad74dc0aa1b (patch)
tree69c7c715ff3abd78bb26a7a4d80dd1da5fd5c08b /plugins/hd/Makefile.am
parent4d01c183b4c1e4c51dff3d9aeec1c01ce13a4323 (diff)
downloadmpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.gz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.xz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.zip
lyrics: converted in-process plugins to external programs
In-process plugins are very problematic. It is much easier and flexible to move the lyrics plugins to external programs, with a trivial protocol. This is work in progress, among the things missing: - protocol specification, including exit codes - plugin installation - plugin search directory - run-time configuration (currently hard coded) - automatic polling (using glib's main loop?) - better and more robust error handling
Diffstat (limited to '')
-rw-r--r--plugins/hd/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/plugins/hd/Makefile.am b/plugins/hd/Makefile.am
deleted file mode 100644
index f4d4608d8..000000000
--- a/plugins/hd/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-AM_CPPFLAGS =\
- $(GLIB_CFLAGS)\
- $(GTHREAD_CFLAGS)\
- $(libcurl_CFLAGS)\
- -I../../src
-
-###----
-
-plugin_headers =\
- ../src_lyrics.h\
- ../screen_lyrics.h\
- ../easy_download.h\
- ../options.h
-
-###-----
-
-ncmpc_modulesdir = @plugindir@
-
-ncmpc_modules_LTLIBRARIES = libhd.la
-
-### libhd
-
-libhd_la_LIBADD =\
- $(GLIB_LIBS)\
- $(libcurl_LIBS)
-
-libhd_la_headers =\
- $(plugins_headers)
-
-libhd_la_SOURCES =\
- lyrics_hd.c\
- $(libhd_la_headers)
-install:
- @$(MAKE)
- mkdir -p ${ncmpc_modulesdir}
- if test -f .libs/libhd.so; then cp .libs/libhd.so ${ncmpc_modulesdir}/lyrics_hd.so; fi
-
-uninstall:
- @$(MAKE)
- rm -f ${ncmpc_modulesdir}/lyrics_hd.so