aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-13 09:11:22 +0100
committerMax Kellermann <max@duempel.org>2009-02-13 09:11:22 +0100
commitef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525 (patch)
treef2f6337166b55efdf825a6f3df2203a222e90a7e /doc/Makefile.am
parentdf9245c2aae7518c813385f7cd721cc17ff27062 (diff)
downloadmpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.tar.gz
mpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.tar.xz
mpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.zip
doc: generate API documentation with doxygen
When configured with --enable-documentation, use doxygen.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e88957483..e246c4607 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -12,8 +12,17 @@ protocol_DATA = $(wildcard protocol/*.html)
$(DOCBOOK_HTML): %/index.html: %.xml
$(XMLTO) -o protocol --stringparam chunker.output.encoding=utf-8 html $<
-all-local: $(DOCBOOK_HTML)
+api/html/index.html: doxygen.conf
+ $(DOXYGEN) $<
+
+all-local: $(DOCBOOK_HTML) api/html/index.html
clean-local:
rm -rf $(patsubst %.xml,%,$(DOCBOOK_FILES))
+ rm -rf api
+
+install-data-local: api/html/index.html
+ $(mkinstalldirs) $(docdir)/api/html
+ $(INSTALL_DATA) -c -m 644 api/html/*.html api/html/*.css api/html/*.png api/html/*.gif $(docdir)/api/html
+
endif