aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-23 10:04:51 +0100
committerMax Kellermann <max@duempel.org>2009-02-23 10:04:51 +0100
commit3b1a9aeca019c05f2e8492d535b4c51043ff30eb (patch)
treee7615207ba660cdbce38495cda6e0f3b32add09a /doc/Makefile.am
parenta4dfab2aee0650970af4244c8f4b6c4d738d6c0c (diff)
downloadmpd-3b1a9aeca019c05f2e8492d535b4c51043ff30eb.tar.gz
mpd-3b1a9aeca019c05f2e8492d535b4c51043ff30eb.tar.xz
mpd-3b1a9aeca019c05f2e8492d535b4c51043ff30eb.zip
Makefile.am: no recursive makefiles
Recursive Makefiles are inefficient and error prone (no proper way to declare dependencies). Since there's no disadvantage in having one single Makefile, let's do it.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
deleted file mode 100644
index 211a23010..000000000
--- a/doc/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-DOCBOOK_FILES = protocol.xml
-DOCBOOK_HTML = $(patsubst %.xml,%/index.html,$(DOCBOOK_FILES))
-
-man_MANS = mpd.1 mpd.conf.5
-doc_DATA = mpdconf.example
-EXTRA_DIST = $(man_MANS) $(DOCBOOK_FILES) mpdconf.example
-
-if ENABLE_DOCUMENTATION
-protocoldir = $(docdir)/protocol
-protocol_DATA = $(wildcard protocol/*.html)
-
-$(DOCBOOK_HTML): %/index.html: %.xml
- $(XMLTO) -o protocol --stringparam chunker.output.encoding=utf-8 html $<
-
-api/html/index.html: doxygen.conf
- $(DOXYGEN) $<
-
-all-local: $(DOCBOOK_HTML) api/html/index.html
-
-clean-local:
- rm -rf $(patsubst %.xml,%,$(DOCBOOK_FILES))
- rm -rf api
-
-install-data-local: api/html/index.html
- $(mkinstalldirs) $(DESTDIR)$(docdir)/api/html
- $(INSTALL_DATA) -c -m 644 api/html/*.html api/html/*.css api/html/*.png api/html/*.gif $(DESTDIR)$(docdir)/api/html
-
-endif