aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorViliam Mateicka <viliam.mateicka@gmail.com>2009-10-24 18:24:29 +0200
committerViliam Mateicka <viliam.mateicka@gmail.com>2009-10-24 18:24:29 +0200
commit7b343eaf5042513e14f4e2f0d0b698ea7c851e15 (patch)
tree0f0025d8589c73c15f35bd1b69d274ea7cf2b996 /configure.ac
parentac830468bf5bad039dd7198bdbd3b73ceb6c7b32 (diff)
downloadmpd-7b343eaf5042513e14f4e2f0d0b698ea7c851e15.tar.gz
mpd-7b343eaf5042513e14f4e2f0d0b698ea7c851e15.tar.xz
mpd-7b343eaf5042513e14f4e2f0d0b698ea7c851e15.zip
add --disable-inotify for configure to disable inotify when autodetected
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ffe89b03..792fcd675 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,8 +121,19 @@ AC_CHECK_HEADERS(locale.h)
AC_CHECK_HEADERS(valgrind/memcheck.h)
AC_CHECK_FUNCS(inotify_init)
-AM_CONDITIONAL(HAVE_INOTIFY, test x$ac_cv_func_inotify_init = xyes)
+AC_ARG_ENABLE(inotify,
+ AS_HELP_STRING([--disable-inotify],
+ [disable support Inotify automatic database update (default: enabled) ]),,
+ [enable_inotify=yes])
+if test x$ac_cv_func_inotify_init = xno; then
+ enable_inotify=no
+fi
+
+if test x$enable_inotify = xyes; then
+ AC_DEFINE([ENABLE_INOTIFY], 1, [Define to enable inotify support])
+fi
+AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
dnl
dnl mandatory libraries
@@ -273,6 +284,7 @@ fi
AM_CONDITIONAL(ENABLE_SQLITE, test x$enable_sqlite = xyes)
+
dnl
dnl input plugins
dnl
@@ -1624,6 +1636,12 @@ else
echo " libcue support ................disabled"
fi
+if test x$enable_inotify = xyes; then
+ echo " Inotify support (autoupdate) ..enabled"
+else
+ echo " Inotify support (autoupdate) ..disabled"
+fi
+
echo ""
echo "##########################################"
echo ""