aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:10:29 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:14 -0700
commite20d3d49b3b269fd637780ee710f991f4d848a51 (patch)
tree0228d16b370e2f48c30f7ec6f746ccb939b01463 /configure.ac
parent33641df09c8b4bd36ee1eff7c6e9651ece877848 (diff)
downloadmpd-e20d3d49b3b269fd637780ee710f991f4d848a51.tar.gz
mpd-e20d3d49b3b269fd637780ee710f991f4d848a51.tar.xz
mpd-e20d3d49b3b269fd637780ee710f991f4d848a51.zip
configure.ac: Move OSX to Audio Output Plugins (nonstreaming), add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e1e6a06c6..579a3fea4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -938,6 +938,17 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
+dnl ----------------------------------- OSX -----------------------------------
+enable_osx=no
+case "$host_os" in
+ darwin*)
+ AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
+ MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreServices"
+ enable_osx=yes ;;
+esac
+
+AM_CONDITIONAL(HAVE_OSX, test x$enable_osx = xyes)
+
if test x$enable_pipe_output = xyes; then
AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
[Define to enable support for writing audio to a pipe])
@@ -955,15 +966,7 @@ fi
AM_CONDITIONAL(HAVE_PULSE, test x$enable_pulse = xyes)
-enable_osx=no
-case "$host_os" in
- darwin*)
- AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
- MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreServices"
- enable_osx=yes ;;
-esac
-AM_CONDITIONAL(HAVE_OSX, test x$enable_osx = xyes)
enable_shout2="$enable_shout"
MPD_AUTO_PKG(shout, SHOUT, [shout],