aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:13:22 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:31 -0700
commitd847593a8e413688f00f50ec72a9057826006046 (patch)
tree4447a9623ca2992f3ee31c4112bcd9f93a34e6d6 /configure.ac
parent1cd5700c3772fdea0a7d3ffc70b8c8efe8d4c958 (diff)
downloadmpd-d847593a8e413688f00f50ec72a9057826006046.tar.gz
mpd-d847593a8e413688f00f50ec72a9057826006046.tar.xz
mpd-d847593a8e413688f00f50ec72a9057826006046.zip
configure.ac: Move OggVorbis Encoder to Encoder Plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8d2bb8998..bdb20f7dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1214,9 +1214,16 @@ if test x$enable_flac_encoder = xyes; then
fi
AM_CONDITIONAL(ENABLE_FLAC_ENCODER, test x$enable_flac_encoder = xyes)
+dnl ---------------------------- Ogg Vorbis Encoder ---------------------------
MPD_AUTO_PKG(vorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
+if test x$enable_vorbis_encoder = xyes; then
+ AC_DEFINE(ENABLE_VORBIS_ENCODER, 1,
+ [Define to enable the vorbis encoder plugin])
+fi
+AM_CONDITIONAL(ENABLE_VORBIS_ENCODER, test x$enable_vorbis_encoder = xyes)
+
if test x$enable_lame_encoder != xno; then
AC_CHECK_HEADERS(lame/lame.h,,
[AC_CHECK_HEADERS(lame.h,, using_lame=no)])
@@ -1308,12 +1315,6 @@ if test x$enable_encoder = xyes; then
[Define to enable the encoder plugins])
fi
-AM_CONDITIONAL(ENABLE_VORBIS_ENCODER, test x$enable_vorbis_encoder = xyes)
-if test x$enable_vorbis_encoder = xyes; then
- AC_DEFINE(ENABLE_VORBIS_ENCODER, 1,
- [Define to enable the vorbis encoder plugin])
-fi
-
AM_CONDITIONAL(ENABLE_LAME_ENCODER, test x$enable_lame_encoder = xyes)
if test x$enable_lame_encoder = xyes; then
AC_DEFINE(ENABLE_LAME_ENCODER, 1,