aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:26:18 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:32 -0700
commitb7ee1f5c40f21be909ff99e88b839a8868e03e41 (patch)
treebfd64c97fbd674c12ac0204b27a34627ee68ef94 /configure.ac
parentb619f5e73d10709bc18674d3577d1dfb4f99125a (diff)
downloadmpd-b7ee1f5c40f21be909ff99e88b839a8868e03e41.tar.gz
mpd-b7ee1f5c40f21be909ff99e88b839a8868e03e41.tar.xz
mpd-b7ee1f5c40f21be909ff99e88b839a8868e03e41.zip
configure.ac: Move Recorder output to Streaming Audio Plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 18 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index bf6964382..d069eed70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1310,39 +1310,41 @@ if test x$enable_httpd_output = xyes; then
fi
AM_CONDITIONAL(ENABLE_HTTPD_OUTPUT, test x$enable_httpd_output = xyes)
-if test x$enable_shout = xauto; then
- # handle shout auto-detection: disable if no encoder is
+dnl --------------------------------- Recorder --------------------------------
+if test x$enable_recorder_output = xauto; then
+ # handle recorder auto-detection: disable if no encoder is
# available
if test x$enable_encoder = xyes; then
- enable_shout=yes
+ enable_recorder_output=yes
else
- AC_MSG_WARN([No encoder plugin -- disabling the shout output plugin])
- enable_shout=no
+ AC_MSG_WARN([No encoder plugin -- disabling the recorder output plugin])
+ enable_recorder_output=no
fi
fi
-if test x$enable_recorder_output = xauto; then
- # handle recorder auto-detection: disable if no encoder is
+if test x$enable_recorder_output = xyes; then
+ AC_DEFINE(ENABLE_RECORDER_OUTPUT, 1, [Define to enable the recorder output])
+fi
+AM_CONDITIONAL(ENABLE_RECORDER_OUTPUT, test x$enable_recorder_output = xyes)
+
+if test x$enable_shout = xauto; then
+ # handle shout auto-detection: disable if no encoder is
# available
if test x$enable_encoder = xyes; then
- enable_recorder_output=yes
+ enable_shout=yes
else
- AC_MSG_WARN([No encoder plugin -- disabling the recorder output plugin])
- enable_recorder_output=no
+ AC_MSG_WARN([No encoder plugin -- disabling the shout output plugin])
+ enable_shout=no
fi
fi
+
+
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
if test x$enable_shout = xyes; then
AC_DEFINE(HAVE_SHOUT, 1, [Define to enable the shoutcast output])
fi
-AM_CONDITIONAL(ENABLE_RECORDER_OUTPUT, test x$enable_recorder_output = xyes)
-if test x$enable_recorder_output = xyes; then
- AC_DEFINE(ENABLE_RECORDER_OUTPUT, 1, [Define to enable the recorder output])
-fi
-
-
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------